Unitiserve ssd not working after power outage

Hi all. 2 nights ago my neighborhood had a brief power outage. Now my unitiserve ssd has stopped working. When I turn it on the cd spinner starts, but the logo light remains flashing and no server is found by the n-serve app on my phone or computer.
I found one thread with a similar problem and the consensus was that the boot up sequence was lost or corrupted and the unit needed to be reset by Naim service. Unfortunately that thread ended at that point so didn’t reveal what actually solved the problem. Does anyone have any ideas? Is there anything I can do myself or will I definitely need to send it away for servicing? Thanks for your help! Robin

Probably it needs a new CMOS battery, which is an easy DIY fix if you are confident of going inside a PC (which is what the US is). But you then have to reset the BIOS to Naim settings and for that you need a VGA display you can connect to the US and a PS/2 or USB keyboard.

If you have the display, you can also restart the US again and watch at which point it gets stuck.

Your dealer should be able to do all this for you. If it’s a new battery then that is a CR2032 that you can buy in Tesco or wherever for a couple of £s.

If reading this leaves you thinking “I’ll have a go”, then I can probably help further, or there is also a very helpful Naim guy who will probably join in if we draw it to his attention. You will also find there are several threads about this already, although not for quite a few months now.



1 Like

Thanks. I did replace the battery but have not done the start up parts with keyboard and mouse. Have ordered a ps2 adapter and will see what happens. May have to get back to you later this week.

Ok well after you change the battery it reverts to the default BIOS for the PC Card and that’s not Naim. Once you have the VGA monitor and a keyboard working, then it’s the work of moments to reset the BIOS to the Naim settings. They are there. You just have to select it instead of the PC’s own.

Of course the problem may not be the CMOS battery, but anyway it’s worth trying that first.



If you have removed the CMOS battery since having this problem you will certainly need to follow David’s suggestion and connect a screen to it.

The fact that this happened after a power cut seems like a bit of a coincidence though (but not impossible if the battery was already low.) The only time this happened to me, I just turned off the power, left it disconnected for a while, then turned it back on and it was fine after that.

Similar non functioning of Unitiserve after power cut. Contacted Naim and got a reply from Duncan Roberts.

  1. Replace battery
  2. Reset Unitiserve using PS2 keyboard and screen
    I managed 1 but didn’t have the hardware for 2. So contacted Infidelity in Kingston who said “bring it in and we’ll have a look “. I took it in they had a look and then fixed it.
    Unfortunately they had a couple of pairs of SBLs for sale.
    Bought a pair, love em.

Thank you all for your help! It just needed a reset using the ps2 keyboard like was suggested and now back in action.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.