UnitiServe suddenly refuse to play music

I was listening, then in the middle of the song, it suddenly stopped. Than it can’t play. I can still see all the album and songs in the app. I can select a song and click play. It says playing, but when I check, the timer bar is not moving. It is displaying the paused icon which means the device thinks it is playing, but it is not and no sound! This is really strange. I tried restart it a couple times and still stuck. I also tried refresh the cache. I connect to my NAS using my computer and everything is working. Please help. I am really stuck.

I unplug it, restart my NAS, and now it says play request failed. I see that before, and it works fine after restart. But this time, I restarted it multiple times and still play request failed! I can’t understand.

Now it is back to the same behaviour. It says playing, but it is not. The timing bar is not moving.

It is fixed now. I disconnect it from the Ethernet hub, connect it directly to the router, and it can play music. The. I reconnect it to the hub and it now can play music. Gee … this is really weird.

1 Like

Often a good thing to try is turning everything off including the router and any switch, also the Unitiserve and NAS and also any streamer if your Unitiserve is sending upon files to a streamer via your network.

Then restart the router and when it is fully restarted, restart the switch and then everything else, one thing at a time.

I suspect what happened was that your Unitiserve’s IP lease expired and your router couldn’t see it properly via your switch, so by plugging it into the router you got a new lease and this continued to work after you reconnected it to the switch.



Oh My Goodness! Even now it can play music now, my playlists are screwed. I have a Favourite list with over 200 songs in it, now it only has 69 songs! Something is corrupted. This is frustrating. Does anyone know if I can recover a corrupted playlist? Is it a file save somewhere?

If you have a back up set for your US data it will also back up the playlists so it should be there.

It could just be that your US needs to rescan the music folder on the NAS, and it hasn’t finished yet. It sometimes does this rather slowly, especially when the files are stored on a NAS and transferred over the network.

If the playlists don’t eventually reappear intact, it’s a simple matter to restore them from backup. Unless, of course, you haven’t set up the backup, in which case you have lost them.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.