Unitserve and upnp plus sqbx

Not to distract in other threads but is anyone running Logitech Media Server ( for sqbx) on Win10 and managing to discover/see their Unitiserve via upnp?

Sqbx sees other upnp devices but doesn’t see the unitiserve. Any ideas to fix this?

I don’t know, but I suspect it is because Win 10 doesn’t support SMB1 unless you activate it specially.



Thanks David , I have that activated and media player sees the US. I suspect it is an interaction between the LMS software /upnp plug in, and Win 10.

I’ll try and find an answer from the plug in developer and report back if he/they have any ideas.

Have you had a look in the upnpbridge config file, is the US listed? Could you try adding it manually?

Good point. I haven’t looked at the file. I’ll give that a try.

Ok File config requires

uuid:FF31F012-73E5-4272-050F-BB0EFF31F012 TiBo Bond 3_B128 TiBo Bond 3_B128 bb:aa:6c:df:b1:xx 1

The thing I don’t have for the US is the udn uuid, Is there anyway I can interrogate the US for that uuid?

The last part of the UUID is the MAC address of the device, not sure how the first part is derived though exactly without some digging. If you have “mconnect” on your phone that will show you the UUID not sure I’ve seen it anywhere in the Naim app though.

Also, have you tried to generate the configuration file again via the plugin, also worth trying switch off/on the autosave function in the same plugin to see if it helps

Yep tried the regen and auto save and looked for a uuid containing the mac address in regedit. Nada.
Looked in the Naim desktop client system info but again no uuid anywhere I can see.
I tried fing but that doesn’t show uuid. I’ll get hold o mconnect and see if that finds it. I’m left wondering if the Naim US needs to be broadcasting a service for the LMS to recognise it as a playable device.

AH, interesting. mconnect behaves the same as win 10 media player. It sees the music shares on the US but doesn’t see it as a playable device. I think I may need someone at Naim to provide the answer.

Just occurred to me, can the US actually act as UPnP renderer? It’s primarily a UPnP server and it’s most likely the LMS plugin is specifically for UPnP renderers

Yes, that would be my guess, but I’d like someone from Naim to confirm if possible.

It’s a server, not a client device. It does also have a local SPDIF output, but it’s not a client that can discover other servers, if that’s what you mean.

It appears to be a simple server, in effect a mini computer, stripped down OS running a player software. It connects to a network to both allow shared folders to be accessed and to see other shared folders on the network. It doesn’t act as a streamer to other clients nor does it act as a pass through client to other devices operating systems, unlike say Tibo devices. I was hoping to find some way of enabling it as a client as it does run upnp, but apparently not the client service side.

Thinking out loud time.

Has anyone played with the idea of adding software to the unitiserve os? If I could I’d add lms onboard alongside the Naim player.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.