Unity Atom volume ring keeps stop working after a while

On my Unity Atom after certain time of usage (couple ons&offs, source changing, etc.) the volume ring on the top of the device keeps stop functioning. It rolls but nothing happens - neither on the screen nor with the volume level. Volume controls on the remote and from the phone continue work fine though (with proper volume level indication on the screen).

What helps is unplugging / plugging again device in the wall socket, it reboots and the ring starts working - but just for a while. (Standing by by an on/off button does not help.)

Tried factory reset - no change. Any thoughts are highly appreciated.

Contact your dealer or Naim support.

Does the atom have the on/off cleaning function in the app? (To temporarily disable the control while you dust and clean it out). If yes you could try toggling it on and off.

Exact same issue as you. I think that started after the last update.

I think that’s only Gen 1 Muso & Qbs

Have experimented a little bit more - the bug occurs at some point straight after changing the source, i.e. bluetooth mode, volume ring works, select internet radio, it instantly stops working. Looks like the firmware issue.

Frustrating to have a function of the unit become problematic. However if it was a firmware bug, it would most likely have been picked up in beta testing and by other Uniti users, namely also Nova owners. I have a Nova and no such issue - IIRC they use the same firmware and operate in the same form. As @paulbysea as already mentioned, dealer first and possibly support would be the best course of action.
If you email support, some additional detail would assist getting a more detailed response. In your last post, changing inputs - detail how is this done, remote, front panel or the app, if the later which and on what control point (details of phone).
Your posts make no mention of which version of firmware your Atom is currently running. It may be easy to simply say latest; for two reasons, it is best to specify so anyone reading this much later, knows the score and second, occasional posts have been made detailing a firmware version number, for the details to reveal that there was a discrepancy.

The firmware is the latest available for my device (3.8.3.5447).

I figured out the following scenario which “breaks” the volume ring quickly&reliably in my case:

  1. Select bluetooth source on Naim. No device connected. The volume ring is working.
  2. Connect some device via bluetooth (I tried a phone, a tablet, a laptop - all the same). In rare case the volume ring breaks straight here in the moment of the bluetooth device connection. But mostly I should follow to step 3.
  3. While bluetooth device is connected change source to smth else from the front panel, i.e. to spotify or to the internet radio. The volume ring instantly stops working here. Only full restart will help.
    In step 3 if the bluetooth device is first disconnected from the Naim device, the volume ring should not break after the source change from bluetooth to smth else.

From the above it looks like the problem occurs in the moment of a bluetooth device disconnection and sometimes connection to the Naim device. And I agree with [bid] this must have started after the recent update as I didn’t notice this before.

Somehow I though the Naim representatives follow this forum. If they doesn’t I will email them separately.

The firmware for me is the same as [RareBird].
Also, the ring stops working as soon as I connect a device by Bluetooth.
At this stage, it’s still possible to change the volume using the remote control.
Note that a soft reboot does not fix the issue. I have to do a hard reboot (ie unplug) to fix it.

Naim staff don’t routinely monitor this forum although some do from time to time. But the best way to get a report of a problem is to contact Naim technical support. A response to a email can be very slow, so phone is usually much quicker.

As a matter of interest, would you mind explaining in what situations you are using bluetooth?
Linking a phone, tablet or laptop, as you mention, will not be the best available quality in most cases.
I appreciate what you report, likely it shouldn’t be happening.
There are a number of us on the beta test team, including @davidhendon, who have joined the team.
We are requested not to discuss the work of the team.
I will however suggest that a few bluetooth questions in general have arisen on the forum in the past, in the context that few people now rely on it; especially given the alternatives including airplay as well as the streaming platforms that Naim now support.
Hence my thought, that if you explain your use of bluetooth, one of us can perhaps raise it in the beta team forum. It’s just another way forward, given few peps use bluetooth; just a thought.

Sure. The tablet and the laptop were connected for testing purposes only to rule out specific incompatibility of my phone when trying to explore the volume ring issue.

Regarding the general question, I’m in android ecosystem and primarily consider android cast for streaming any local content from my phone or from apps that are not built-in in Naim. My cast experience with my phone (samsung s10e) is not flawless though:

  • sequential tracks change is performed via a noticeable pause: on player controls it looks like the previous track ends, the player is put on a pause for a few seconds, the track changes and the play mode starts again;
  • sometimes the above process hangs in the pause mode, I need to light up the phone for the next track to start playing or press play manually again;
  • playback may sometimes interrupt for about 5-10 secs in the middle of a track and then resume.

Also I have the following scenarios where bluetooth helps out:

  1. Watching sports live on a tv with an alternative commentary from youtube. Youtube video app can not cast to audio-only devices.
  2. I use a separate simple app for podcasts downloaded on my phone to avoid mixing it with my music library. This app does not support cast.

Appreciate if you are using android, then you don’t have the option of airplay. Try a search here on the forum, you may find others have used different casting from android devices to Uniti, at least a possible workaround for you until this is addressed, if it’s a bug.
Best to email Naim support with all the information, if you haven’t already done so, the forum is not generally followed by support staff.
Interested in your comment re casting from you tube app - in the Apple universe, the youtube app does cast to Uniti, but then it is using Apple’s airplay.

An update on the above - I sent a video of the bug to the Naim support some time ago, today they replied that the issue is discovered and they are working on fixing it in the next update (no dates though). Fingers crossed.