UPnP servers take an age to show up

I’m running Asset UPnP on a ridiculously underpowered Windows 10 PC. In mitigation, Asset UPnP is the only application it runs, apart from the OS. If I select UPnP from the Naim app, it can take an age (in reality, probably a minute or two) for the Asset instances to show up. Once I’ve selected some music, it plays fine. But at the end, to select some more music, I have to back out all the way to the Naim app home screen, reselect UPnP servers (and wait another age) and start again. I’m sure the problem lies with the PC. Is there anything on Windows or Asset that can reduce the time it takes to publicise its presence? Would a new NAS (I’m thinking of the new Synology DS220+) fix the issue once and for all?

I run Asset on a Synology that has a slightly low powered OS with dual core 1.066 GHz & 512 MB DDR3.
It opens in the Naim iOS app practically instantaneously & the same when selecting another album, & no need to ‘back out’ of anything for anything.
I suspect it is the PC & that a pukka NAS is the solution.

I run Asset on a Dell Laptop with dual core 1.2GHz & 1GB RAM…I have no problems whatsoever with the Naim app. The only delay I sometimes see is when I use it first thing and the NAS drives may have gone to sleep and have to be woken up, I sometimes have to tell the Naim app to play the track twice but only first thing.

When you say ridiculously under powered Windows 10 PC what do you mean exactly? No doubt a faster PC will help but I doubt it is purely the hardware spec that’s causing your problem. I’ve also run Asset on a RPi (Model B) with 512MB and I think the processor is 700MHz, whilst a bit slow it wasn’t as bad as you are describing.

Of course it could be all the bloat of Windows 10 causing some performance issues.

What’s the network configuration supporting this setup ?

I would say this has nothing to do with the pc but your network. Asset is pretty low CPU usage and doesn’t require anything fancy. Likely your network is slowing down discovery of the server. What is your network config currently?

1 Like

You nailed it, the network is almost always the issue. And if a “mesh” then even more so.

The CPU is an AMD E350 @ 1.6GHz. It is running the latest build of Windows 10 (1909) but it is painfully slow.

I doubt that’s the problem. It’s got 8GB of RAM and Asset is the only thing it has to do.

Please explain. Yes - I have a Google WiFi mesh network which is, in every other respect, wonderful.

In my experience if the Google pucks are using wifi to “mesh” then sometimes the required network discovery packets get lost or take a long time to “recirculate” at times, so to speak. I would recommend you run ethernet cables for each puck back to a switch to connect it all together. It is not easy nor convenient for sure, but there is a price to pay sometimes for “plug n play” as you may have discovered.
First thing though, check UPnP is enabled in the Google wifi settings. Open Google wifi app, Network and General -> Advanced Networking -> UPnP.

Does the strength of the wifi signal contribute to the responsiveness of the Naim App? I use an Ipad Pro and when I’m going through the menu on the touch screen it can be a little slow b/w menus. Not terribly but it doesn’t pop and snap like a typical app.

Hard wiring my devices is not an option - that’s why I have the Google mesh WiFi. Slightly concerned that could be the problem though; my wife would be unimpressed if I splashed a few hundred pounds on a NAS and it suffered the same way. Installing Linux is an option, but a bit of a faff. I think I’ll start by installing Asset on one of my grown-up Core i5 Windows computers and see if they’re any quicker.

Thanks for all your comments.

I think trying a different device is a good idea to prove whether it’s the network which I suspect it is.

Even on a slow Windows PC this should run really fast as Asset will run well on a ‘matchbox’. Even a first generation Raspberry Pi performs really well with Asset running on it.

1 Like

Final comment. I installed Asset on my (pre-retirement) work computer and that instance shows up immediately on both the Naim app and BubbleUPnP. So it’s the computer, not the network that’s the problem. I shall now order a Synology DS220+ to replace the underpowered Windows box. Mrs H will be thrilled.


Good and interesting result. I would give it a few days running on your work computer to be sure the “discovery” issues you were seeing on the old computer have finally been resolved.

Just a thought in case your defunkt Windows PC was connected over wireless - you did say you are all wireless. But how are you intending to connect the Synology to the network?? its not wireless & must connect via ethernet.

I’ll connect the NAS by cable to the spare Ethernet port on the primary Google WiFi box.

1 Like

Running a server on wifi is almost always a bad idea. Info about that key point was missing from your initial post.

That didn’t seem to worry Asset running on my work PC (which is also connected by WiFi). But you got me thinking… I could attach slow PC by cable to the primary Google WiFi box (as I intend to do with the NAS) and then control it using Remote Desktop from my work PC. Usually it sits under the TV which is used as its monitor (the primary Google WiFi is in another room with no monitor available). This sort of tinkering drives my wife nuts.

If you set the old laptop up as a “server”, I can’t see why it should not run the minimal resource requiring and well built Asset UPnP server without problems.

Set the laptop up so that it doesn’t go to sleep and the hard disk is not being turned off at some time interval. Set the display to turn off after 1 minute AND hook it up via ethernet, disabling wifi. Close the lid and set it out of sight. Easy to do and worth a try.