Using Ethernet Unity Atom can’t find rooms

Hi Folks
I like to use an Ethernet cable to stream my music its more reliable and faster than wifi. But…I can’t find rooms and control Unity Atom from my iPhone when it’s wired through Ethernet. Is there something I’m missing here?

Hi, the first thing I would try, if you haven’t already, is restarting your router. Better still, turn off your router, Atom, iPhone and any other devices. Leave it for 5 minutes, then turn on the router. When that’s fully up and running, turn on the Atom, and any other devices, one at a time.
If that doesn’t work, you may need to look at how your network is configured.

Hi thank you. I don’t have a problem with wifi except for a bit of lagging now and then which is why I would prefer to use ethernet.

When the Unity Atom is connected to Ethernet it disconnects from wifi.

The Atom will automatically use wired Ethernet if connected. Unplug the cable and it should revert to WiFi. Best to try getting the wired connection working properly though.

Ok That’s the problem
When it’s wired I have no control with my phone app.

Have you done as Chris suggested? The router probably needs restarting in order to assign a new IP address. Once that’s restarted, turn on the Atom.

The iPhone doesn’t connect directly to the Atom’s WiFi, it finds it over your network, so as long as the phone is on your WiFi, it should still work. If it can’t find it after you connected the cable, it’s probably just confused, and a network restart will probably sort that.

Hi Chris
Sorry for the delay. Yes I tried that but same problem. I guess it might be because I’m passing through an Ethernet switch. What do you think?


Turn everything off. Turn on the router. Wait. Turn on the switch. Wait. Turn on the Naim. Turn on the app.

Thank you. All fixed!

Excellent. It’s just a matter of doing everything in the right order.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.