Volume only adjustable in 5s playing Spotify on Uniti Nova

I have a weird bug when playing Spotify through the Uniti Nova: I can only adjust the volume in steps of 5, e.g. if I try to go from 20 to 23 it skips back to 20, but it will stick at 25. This happens whether I use the volume wheel or the remote, but it’s ok if using a NAS drive as source or the radio.

This seems to have happened since the new Focal / Naim app update. I’ve tried restarting everything and installed the latest firmware for the Nova.

Any ideas please?

Are you using Spotify Connect or Airplay? It’s been a while since I’ve used Connect, but with Airplay (and Chormecast) the volume jumps for a single press of the button are far to big in some apps, although different apps seem to vary in this respect.

Thanks for the reply. I’m pretty sure I’m using Spotify Connect. I’m doing what I’ve always done, which is open the Spotify app, choose some music, tap the little speaker icon and then choose Uniti Nova from the list of devices (NOT Airplay).

Anyway, I’ve just tried Airplay instead and volume behaved fine (unless I use the volume control on the iPhone, in which case it does indeed do big jumps)… I then went back to Connect and it’s now fine there too! How do you explain that??!

Apple’s volume controls are bonkers - I believe if you use the basic controls (especially physical) there are only 16 levels. If however you go to ‘control centre’ you get far more granularity.

Not recently but in the past I’ve sent feedback that volume changes of 100/16 (roughly 6.25) when controlling AppleTV audio out via remote ia juat too much and I wish they had a setting to control volume changes with you being able to set increases/decreases to a particular n/100 value.

Thanks Alley_Cat - interesting and thanks for the Control Centre tip. I never normally use the iPhone volume controls anyway - much prefer to use the Naim remote control, which gives nice gradual graduated steps (at least it should do!). Very important to get just the right listening level!

Update! The problem is still there after all. If I select Spotify Connect I can only adjust the volume in units of 5, UNLESS I first select Airplay and then go to Connect - then it is ok. If I come back and repeat next day (or exit the Spotify app and reopen) it is back to square 1.

This seems like a bug introduced by the new Focal / Naim app. Is anyone else getting this? How do I report this to Naim?

Hi Nick
I discovered the same issue since updating on my iPhone 12 fromiOS 15 to 16.
My iPad Pro which is running iOS 15 (because there is no 16 so far available for the iPad) can still adjust the volume in single steps.

To me it looks like it’s iOS 16 which is causing the issue.

So far no solution on this. Really anoying because it worked fine before

I have contacted Naim. But no reply yet.
My remote and app for Uniti atom, the volume does not respond then jumps usually up. Very dangerous for speaker levels.
Also Spotify in 5 increments. I am using iPhone 13 mini but seems to have happened sinc firmware update?

Just to follow. I have done a factory reset and reloaded the Naim app but still having volume issues.

Thanks StreamKing - spot on! I too have an iPhone 12 updated to iOS 16 and an iPad running iPad OS 15 and get exactly the same result. Very annoying as you say. I don’t know how you tell if it’s iOS, the Naim app or the Spotify app - some sort of incompatibility somewhere. Maybe it will get ironed out by an update at some point. I’ll post here if I find an answer. P.S. iPad OS 16 is out on Monday, so that will probably mess up the volume control too!

I too have now reported the problem to Naim. I’ll report back if I hear anything. Response times are “heavily delayed” they say.

Hi Nickrich,
Before I posted the volume issue here in the forum I contacted Naim Support but didn’t receive any reply so far since more than a week.

I made the same observations when I was using the previous version of the Naim App & iOS 16.
The volume adjustment was only possible in 5s.

With the ipad and iOS 15 it works normal. I can adjust the volume in single steps. Same with iOS15 and new Naim Focal App.

When I use the iPhone 12 with iOS 16 and new Naim Focal App the issue still exists.

So for me either iOS 16 is the issue or the Spotify app.
Because another strange behaviour is of I use the Naim Remote that came with the atom. The adjustment works in single steps but the set volume ju,ps then back or forth to the original setting from the iPhone.

I plan not to update promptly to iOS 16 on my iPad .

They are apparently very busy, but normally they should reply within 2 or 3 months.


There seem to be three threads with very similar issues on volume control with the Unitis. Hopefully Naim will see this.

1 Like

I’ve had a response from Naim:

“It appears to be an issue with how iOS 16 reads the Spotify commands, and because Spotify is not integrated into the naim app, there’s nothing that we can do to change this. Hopefully, Apple and Spotify will sort this issue out soon, as it happens with Spotify on other brands too.”

1 Like

Apple don’t generally reply but it may be worth flagging this to them using one of the feedback links for your Apple device:

Might be worth deleting and reinstalling the Spotify app:


May or may not help, but a search doesn’t turn up much else there recently.

Just tried the hint to delete the Spotify app and reinstalled it from the App Store.
Unfortunately nothing changed… volume issue still exists.

At least it works well on ios15 & iPad so no need to shift on that device to iOS 16 soon

I tried that too - same result! Thanks for the tips Alley_Cat. Might try Apple feedback next.

That’s a shame, it’s very odd.

I have a credit card app which has refused to work on my iPhone since an update earlier this year -it opens but constantly tells me it can’t get account information. Bonkers.