VPN and Naim app

I run Private Internet Access VPN. The Naim app starts but fails to discover my kit. Suspend the VPN and all ok. Not a major issue therefore, but would be nice to have an exception or something

It’s simply because your Naim kit is not on the same network that your phone/tablet is on. The App can’t tell you to turn off your VPN because it has no way of knowing there is one in use!

1 Like

Interesting, I use a VPN on the iPad that mostly control NDX and 272 (both wired) and do not have this problem. However, I have had it with TIDAL and have to set the VPN to the same region as I’m in for this to work.
I would switch streamers and router off, restart and then with VPN on try connecting and see what happens.

Same here, I’ve used Express VPN on my phone quite a bit over the last few years and it has never been a problem.
Not sure if running a VPN on the router would cause such an issue.

Not quite understanding. All kit on the same subnet 192.168.0.x. only difference is Ndx2 is wired ethernet with a static ip address and the phone and tablet are dhcp

I think it is recommended that the streamers are dhcp and not fixed IP. Can you try that and see if it makes a difference?

Sorry, I stand corrected it is set to dhcp. I got a new router and ended up having to do a factory reset on the ndx2 so it is now set to dhcp as is the tablet and phone. I tried setting a UK location on the vpn but still doesn’t see it. I can open a ticket with the vpn provider. Not the end of the world just a bit frustrating!

Sounds like your VPN is sending all traffic down the tunnel.

There’s usually a setting on VPN clients something like “allow local/LAN access” which sends 192.168.0.0/16 to local LAN instead of tunnelling. Look for that and enable?

On your VPN it appears to be Setting/Network/Allow LAN traffic (going by Google)

Thank you Iain Gold star. Found the setting just where you said and works fine now.

10 shilling note in the post!

3 Likes

Glad it’s working :smile: