Why is my FLAC stream transcoded to MP3?

Hello everyone,

I’m a totally newcomer to the Muso Qb.

Everything seems to work including connection to a DLNA server (JRiver 26 running an iMac). The Muso has found the JRiver server and vice versa.

I have tons on files in FLAC format. I know the Mu-so is capable of decoding many different formats including FLAC and yet when I direct JRiver to stream to the Muso, the FLAC is transcoded to MP3 (reported on the Muso App). There is no such issue with a directly connected DAC that I have.

Is there something in the JRiver or Mu-So configuration that is needed to ensure there is no transcoding? I am a real purist when it comes to my music :grin::grin:, or am I stuck with the crippled MP3 format. I’m also asking the JRiver user forum about this problem.


Hi, the Muso can handle FLAC, and it certainly doesn’t transcode one format to another. So I suspect this is a JRiver issue, but I don’t use it myself.

As Chris says, the Qb cannot and does not transcode. It simply plays what it’s sent by the server. The issue is therefore in the configuration or functionality of your upnp server software.

Once you work out where the setting is, see if you can set it to transcode flac to WAV. This may sound a little better as it reduces the work the Qb needs to do.

1 Like

This is a config setting in jriver, you need to disable transcoding. Please see here

Please see @robert_h post below

The client options mentioned above are for secondary instances of jriver running on another computer using the primary instance as a main library, or for jremote running on an iPad.

You need to click on the “add or configure dlna servers” then set it per my link.

Hi, please wipe your access key from the image, you have authentication disabled so I can connect to your library if I want.

Thank you - I think I must still be half asleep.


Ah true your router might have blocked me. I have qobuz so more music than I know what to do with anyway, and most of it I’ve never heard of.

Thanks everyone for your inputs and suggestions. @ChrisSU - you are right, the Muso does not transcode. @Robert_h - I tried setting jRiver according to your comment. At first it did not do anything. Then I decided to delete the DLNA server and added a new one without transcoding and I glad to say that it worked.

Thanks again everyone for your help.

Sorry forgot to mention you’d need to stop and restart the dlna server, but deleting and setting up again does the same thing. Regards Robert

@robert_h. Thanks.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.