Wired Network Issues

Firstly, apologies if I am posting this in the wrong place.

I have had a very good experience with a wired streaming set up for several years - until now!

I play music streams (either CDs ripped to a Naim Uniti Core and also one of the cheaper Melco digital music libraries, and also Qobuz streams) on a Naim NDX2 (with which I now use the new NPX300 power supply in place of my previous XPS2) and from there to a Naim Supernat2.

My domestic network is based on ethernet cable running from a BT Super Hub with full fibre to the premises. There are ethernet sockets at different points of the network to allow connection of various pieces of kit (TVs, Apple TVs, BT TV box etc).

All worked well until a few months ago when - and I cant figure out why - 2 of the 3 locations (one being my hifi as described above) dropped off the network. After much trial and error I find that if I connect the Melco directly to the ethernet wall socket and from there to the NDX2 using the Melco’s ethernet ‘player’ socket it works fine - both the Naim/Focal App and the Roon App can see both the Melco and the NDX2 and can control both as normal. Also the Melco can access the internet for purposes of looking up details when ripping a new CD.

But if instead of connecting the Melco directly to the ethernet wall socket I instead add a switch (to allow a wired connection to a tv and also an AppleTV box) and run a cable from the switch to the Melco then the network connection fails - neither the Melco nor the NDX2 can be seen by the control Apps and, for good measure, neither theTV nor the AppleTV can establish a wired connection to the internet.

It’s not the fault of the switch - I’ve tried several different makes including the Etherregen switch I used successfully for several years.

The only clue to what may be happening is that one of the ethernet cables that runs from my BT Super Hub to a different TV Room may be disrupting the network. When I disconnect it from the network the 2 other locations (including the hifi) work fine irrespective of whether I add a switch at each endpoint. But I need to keep the ‘rogue’ cable connected as it delivers the network to the TV Room (where it connects to a switch without causing any disruption).

So, I’m left with a wired network that only works if I do not use an ethernet switch at 2 of the 3 endpoint locations. The result is that at those 2 locations I can only connect one device to the ethernet socket - ie the Melco/NDX2 in the case of the hifi - and I have to use wifi for everything else at those locations. And yet at the third location I can connect several devices to the network using a switch without any issue.

Apologies for the long post - writing it was therapeutic! My Question is : can an ethernet cable continue to carry the network but perhaps introduce a form of electrical or other interference that would disrupt the overall network in the way I have described?

I would be grateful for any insights from the Community.

Perhaps @Richard.Dane could move this to a seperate thread rather than jump on the back of this one. It will keep replies and advice clearer for each poster.

1 Like

A couple of things worth mentioning.

Firstly, have you powered off everything (e.g. the hub, phone, NDX2, Melco) for 5 minutes, then power on hub, wait 5 minutes, then power on everything else? Also when I say power off, I mean remove plug from wall on all devices
Secondly, it isn’t clear from your description which cable is used for which test, and which short patch cable is used. You could well have a cable issue, or an RJ45 connector issue, so some more testing around here being specific about which cable is used in which case. You can of course buy cable testers
Lastly, and just a thought, I dont know how well your BT hub works as a switch to all those cables outlets, but have you considered a dedicated switch, e.g. Cisco 2960

A diagram would probably help here. :thinking:

So it sounds like you have a bt home hub and connected to it you have three ethernet cables going to three locations in the house.

  1. Do the cables terminate at the router wall with ethernet panels?
  2. Do you know the type of the cable, cat5e/cat 6 etc
  3. Do you have an ethernet tester (these are super super cheap on ebay or amazon)
  4. Have you set anything to fixed IPs? If so are you certain, absolutely certain that there are no duplicates?

How do you know the network is not working and items have ‘dropped’ off the network? Very very unlikely, remember a UPnP discovery app not showing devices, is unlikely to be about the network… more about the UPnP application interoperability.

So when you connect all your switches and your hosts/clients to the switches, you can log onto Smart hub, and you should see all the connected devices, including their network address and IP address. Sometimes you can see a network address without an IP address, depending on the device connected this is totally fine.

If you cant see the network (MAC) address for the connected device… then it’s not on the network. Another name name for network address is a Medium Access Control (MAC) or Physical network address. It is the address used within a subnet.

On the Smart Hub, you can see network connected devices under my My Devices, then Ethernet, and you see the number of devices connected to each switch port either directly or via connected switches, and a list of all currently connected devices with their MAC /Physical network address and the private ip address if used on the network.

If you can see the network addresses for the connected devices/clients in the SmartHub, the low level network is fine, and you then may have an issue with SSDP interoperability combination issues as used by UPnP with devices connected to your network with your particular UPnP based application. You might need to disable UPnP on various devices to explore further, or issue a ping to the SSDP discovery group IP address and see which clients return. ( 239.255.255.250 or ff0x::C )

The BT Smart hub works fine with many multiple switches and connected devices… it does well up and down the land in consumer and small site setups… I don’t know what the MAC /CAM address table size is but I suspect it is at least a few hundred addresses and likely irrelevant to what you are seeing. I have 4 switches connected to my BT Smart hub… all with UPnP devices of of various on them, but no Melco…

Think your autocorrect kicked in here Simon.

1 Like

Thankyou for this reply - and the other helpful replies I have received.

In my system a single ethernet cable runs (using Cat5e cable) from the BT Super Hub (located in a downstairs room where the Openreach fibre optic cable enters the house) to another location upstairs where a switch ‘divides’ it into 2 separate Cat 5e cables. One of these cables runs to an Ethernet socket behind my Hi-Fi (in my upstairs Study). The second cable runs to another location where it connects to a second switch. Again that switch ‘divides’ it into 2 Cat 5e cables one of which terminates at an Ethernet wall socket beside my computer and the second cable runs to yet another location where it terminates at an Ethernet wall socket. A (third) switch connects to that socket and feeds wired connections to the tv, BT TV box and Apple TV box.

So, to recap, a single ethernet cable runs from my BT Super Hub and 3 switches are used at different points along the ‘line’ to serve 3 ‘branch lines’.

The TV Room - which is the final ‘stop’ on the line always works without fault.

The problems arise when I try to add another switch at the HI-FI - as I mentioned in my original post it’s ok if I connect the Melco directly to the wall socket, but if I add a switch (to be able to add wired connections to a tv and other appliances) nothing connected to that switch works. I’m wondering whether the Melco doesn’t work with other third party switches (they make a hugely expensive one of their own)?

I have had the ethernet cables tested and they all test ok and a green light shows that each connection to a switch is working properly.

All very puzzling.

I’m guessing Simon’s last phrase may be of relevance so it may be worth contacting Melco.

Ok so you are bunnyhopping one cable as it were. Whilst not perfectly ideal it should still work.

Next question are the switches unmanaged?

It feels to me like a conflict is coming in when all devices are connected to the network which would lead me to consider do you have an IP conflict. Is it just the melco that falls over?

I had an issue recently with my BT Smarthub-2 wher the iPad app was not not opening some UPnP devices, sometimes it would other times not, it turned out to be an IP Address conflict, so I agree with Gary, it’s worth considering.
I found my iPad had acquired a new IP address when it’s set to DHCP and “always use this IP address”. It had also reset to the ‘private’ IP address (the MAC address).
I removed all the iffy IP addresses, ran a whole house router power cycle and everything sorted itself correctly.
As to what & why caused it, I never found out.
But a whole system power cycle and making sure it’s restarted from the router first, and let it finish before starting the next might be worth trying.

The IP conflict would only happen if there are some static IP address allocation, otherwise the DHCP server would take care of it, unless there are multiple DHCP servers in the house?

No my point was if he hooks all his ethernet cables up, the melco goes tits up, so perhaps what ever he is plugging in is sharing an IP. This assumes he has set some fixed IPs (rarely necessary in the home environment) as per my frist post on this thread.

That is what I would suspect.

“Bunnyhopping” - I hadn’t heard that one but I see what you mean! I think of it more as a single (rail) line running from the BT Super Hub to the TV Room (the line terminus). There are 2 ‘branch lines’ along the way, with switches acting as the ‘points’ so that the line can also serve first the Hi-Fi and next the PC before it reaches the TV Room.

If I connect the Melco to the first branch line on its own it works fine and the Naim and Roon Apps can see it and control it (and the NDX2 to which it is connected via the ‘Player’ socket on the Melco).

If instead I connect a switch to the branch line in order to connect the Melco plus a tv and an Apple TV box, none of them work. The Melco and the NDX2 can’t be seen by the control Apps. Also the tv defaults to a wireless connection and the the Apple TV gives an error message and has to be connected wirelessly instead.

The same with the PC.

But, to add to the confusion, the fault appears somewhat intermittent. For example, this afternoon I tried switching off the wifi feed to the PC (an Apple iMac) leaving it with a wired connection which normally doesn’t work and - to my great surprise- the PC worked perfectly! I have encountered this before but it usually only works for one day and stops connecting the next day and I have to go back to wifi.

I am going to turn everything off this evening and unplug them as recommended and when I restart them (beginning with the BT Super Hub) I’ll see whether this makes any difference.

My suspicions then would be int he infrastructure, determine at which point it fails, then run a temporary run of cable to the next hop to see if it resolves it. Willing to bet one of those ethernet cables is not the full ticket. They can ‘go off’ particularly at the wall outlet connections.

Are the switches unmanaged?

Yes, I suspect you may be correct about one of the cables being off (the ethernet sockets should be ok as they were checked out recently) or possibly an RJ45 connector.

The switches are unmanaged.

Thanks again for your advice.

Yes, thanks, media access control.

And everything is fine when you don’t connect the Melco and leave for a while or power cycle ? I think you have your answer.
Did you follow though what I suggested and check your Smarhub connected devices page, what did you see?
I think you’ll see your network is absolutely fine, but you may have a faulty set up device such as a Melco.

As Gary says you shouldn’t be using fixed or static ip addresses, if you do, and you have a conflict then devices may not abe able to determine the correct which MAC address to use when they use the ARP protocol, and so physical network (MAC) address resolution fails or becomes unreliable and devices can spring into action and then die… as devices are clashing with each other, which can cause resolution failure at a segment (such as between switches) for a given device or even force a failure because the assigned IP address belongs in another subnet.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.