3 steps forward, 2 backwards (Raspberry PI DLNA Server)

1 Step forward

Found a few odds and sods and reassembled a Raspberry Pi 4 with a case/heatsinks/fan which had previously been plonked bare on the floor running Gentoo Player, it worked for the most part.

1 Step backward

Backed up the old SD card (hopefully) and decided to install Volumio which looked quite nice, but completely missed the fact it was a player and did not support DLNA rendering to the Nova.

2nd step forward

Bought an old Apple Airport Express for a fiver from CEX - in hindsight I’d stupidly updated the final version made which I had to enable Airplay 2 - great for multiroom (only if you’d use it of course) but makes it play AAC rather than CD quality as far as I can tell from various web analyses, unlike the original Airtunes/Airplay 1 on older Express models.

A bit of tinkering and bizarre to find that Alley_Cat’s new secondhand Express was named Alley’s Airport Express - spooky.

A bit of faffing and got it to extend my downstairs Time Capsule with a simple configuration selection - wow, had I known these things integrated that easily I’d have bought several years ago.

2nd step backward

Great, so now I have a CD quality capable Airport Express with optical out for £5 ‘alive’ on the network, so hooked the mini-Toslink>Toslink optical cable up to the Topping 10Ds.

No sound at all selecting it as the Airplay destination.

Silly me of course.

10Ds only has optical out, and removing the USB cable hoping it would work via optical just shut it down as the 10Ds is USB bus powered.

:woman_facepalming: :person_facepalming: :man_facepalming: :scream_cat: :pouting_cat:

3rd step forwards:

Decided to peek at Audirvana again, don’t like the current subscription model, and had unsubscribed.

In my account I managed to download a paid/purchased version of older Audirvana 3.5 which works on Apple Silicon. In fairness, it was easy to de-register the older installations on older Minis to enable it to work and to my surprise it’s a hell of a lot more stable than a couple of years ago.

So now have it playing via USB to the Topping 10Ds in the study and it’s sounding pretty nice with local files or Qobuz streams.

piCorePlayer supports DLNA.


1 Like

Thank you very much, I was going to ask what people are using these days on the Pi.

Will definitely take a look. Volumio looks nice superficially, it just doesn’t really do what I assumed it would (possible miniDLNA plugin I think, but unsure where to get that).

1 Like

I think MoOde Audio will do what you want. I run it on a number of Pi3 with digital And analogue HATs. For sure there’s a section in System Config that mentions DLNA Server, although I’ve never tried it .

1 Like

I couldn’t quite work out last night how it integrates with LMS/Squeezelite whatever, but it was very late so will look again when I have some peace and quiet here.

Cheers, have seen MoOde Audio before, another worth a look.

Don’t have any HATs currently and was mainly planning to use it connected to the network in the study to serve other devices via DLNA.

Gentoo Player worked ok, but I think it may have become a subscription model at some stage. Probably don’t use local server based playback as much as others do, but the RPi had been lying bare and dusty for too long so seemed logical to try and resurrect when I found the bundle box with case etc in it.

I may have confused Volumio with Serviio which I used ages ago, superficially can’t see a simple way to install Serviio on the Pi, but I think you can, just that there isn’t a simple disk image to write to SD.

New RPi 5 shipping soon (or has done for 1st wave of pre-orders).

LMS/Squeezelite is integrated into piCorePlayer. There’s (a farily well hidden) link to LMS at the top of the window.
Screenshot 2023-10-31 115104

1 Like

Thanks for that. So a relatively straightforward install?

I’ve not tried to install anything yet, I think LMS/Squeezelite may have put me off a little as years ago I tried to configure several components on a Pi to allow lossless streaming from Qobuz via Chromecast which used LMS and BubbleUPNP I think - couldn’t get it to work, but the need was to some extent obviated for Qobuz when it became natively integrated on the streamer.

As well as a Qobuz LMS plugin, there’s also a Chromecast plugin (although I’ve found it a little flakey, although I am running PCP on a first generation Raspberry Pi!).

1 Like

Sorry, mised your question.

Simply download 32- or 64-bit version, flash to SD card, boot and logon to web interface to configure. (PCP and LMS configuration is seperate, but down via web interface.)

1 Like

Definitely more stable. I’d happily revert to 3.5 over Studio’s subscription model, but now find the iOS remote app hopeless with 3.5, while it works reasonably well with Studio.

If I were a more cynical type, I might suspect that’s an Audirvana feature rather than a bug :thinking:

1 Like

Is that only in the paid version which I did not trial?

I couldn’t find a setting to enable this specifically.

This was testing with the pi, an attached portable USB drive it had analysed, and connected to the network via ethernet - could access the web control page player on my iPhone or Mac but could not get any audio output destinations to appear. From memory it only gave the pi headphone or HDMI as output options in various settings.

I think I managed to get into a menu of ‘other’ audio outputs but Nova certainly wasn’t there while it was on other devices.

Or have I got my terminology back to front?

I couldn’t find a UPnP setting, though wonder if I was looking in the wrong place.

Even if it was a paid for feature I’d expect to see it as there were several options I clicked on which indicated they were not available in the basic product.

I’ve just got MoOde up and running (odd as I thought I’d put piCorePlayer on the card last night!), and that does appear in the Naim Server selection once I enabled DLNA Media Server.

Music plays and I can mount the USB attached drive over the network using samba to transfer files over quite simply, which is easier than gentoo player as that would have required use of ssh for file transfers from memory.

I’ll give MoOde a bash for a day or so, and can then revisit the other two.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.