504 error with Rovi booklet display - still occurring

The original thread from last year was closed but there is no resolution noted. I have this issue all the time on the Naim app on my iPad so any guidance gratefully received.

This is a gateway timeout so a network issue, what is your home network setup and are you using a proxy server?

Just to check, when you say all the time… do you mean literally all the time, or is there a specific query that always returns 504?
Normally 504 means the issue is in the cloud, and the remote end is not working responsively enough between its servers.
However if literally this is all the time for everything on Rovi, then more likely a misleading message… and as suggested above check that you haven’t got a proxy setting in appropriately set on your streamer.
So if you have no proxy makes sure all the settings are clear.
Also check all setting such as DNS, IP addresses, subnet mask are set by dhcp from your broadband router… and don’t manually set any including DNS.
Ensure you have no internal NAT perhaps from some fancy consumer ‘mesh’ systems, and your wifi is bridged normally to your broadband router. Also ensure you have only one dhcp server, and that is on your isp router.

Same here @Quickben
Recently I have the same issue 9 times out of ten attempts. Either 504 or 403 (forbidden!). I think I also had one that said ‘illegal path’!
Only started happening since the last 2 months or so. Also using iPad.
Of the 1 in 10 which come up with a booklet, 90% of those booklets are the wrong one. Something strange that didn’t used to be the case is now going on for sure…

I would concur. I’m also getting system error 504. It happens when I want to look at more detail in the booklet. It happened sometime last year and has suddenly reappeared as an issue.

I tried searching through the old threads, but can’t spot how the situation was resolved.


Thanks Simon for the things to check. As is to be perverse, I went and tried accessing the booklets from the app and it worked happily for that session. And then 504 errors again when I cam beck to it a few hours later. Have now accessed from the iPhone just now and booklets being served. I think I can rule out an issue in my local configuration but there does seem to be something amiss when it comes to delivering the content; which I would presume is potentially outside the Naimiverse.

I think that sounds reasonable if it’s working mostly… and you don’t have an outbound flow firewall, which I think is unlikely.

Hi guys,

We’ll chase Rovi again about this. They fixed it about 4 months ago, but the problem has crept back. It’s a server side issue in their system that has a habit of reoccurring.

Apologies for the inconvenience.


Steve Harris
Software Director
Naim Audio Ltd.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.