AirPlay connectivity problem

Hi,
My iPod Touch cannot ‘find’ my Mu-so via AirPlay.
Bluetooth it finds and connects straight away.
Any help much appreciated.
Cheers, John

Hi John, first question: is the AirPlay input on the Muso enabled? It’s probably enabled by default, but worth checking just to be sure.
Have you been able to use AirPlay with other devices, either from the iPod, or to the Muso?

Hi Chris,
Thanks for the reply.
My wife’s iPhone finds Airplay and connects with no problem.
I tried my iPod again today and oddly, after about 15 minutes, Mu-so did appear on the Airplay drop down. First time for ages!
I have tried unplugging Mu-so and restarting my iPod but to no avail.
Both Mu-so and iPod are up to date firmware wise.
I’m stumped.
Thanks, John

I assume, all the devices are connected to the same home network / WiFi (via a home router or similar)?
Does the iPod have an older iOS release than the iPhone? Does it show any “general performance issue” when working on WiFi?

(Just trying to check, if there’s something in the local network, which could put an issue on iPod <-> Mu-so network connectivity; could also be the iPhone has 5GHz range enable and iPod not or so…)

What router are your using?

The reason I ask is I had a similar problem with a Muso and a Vodafone (Spain) router (a Virgin Superhub lookalike.)

I reported it to Naim and got the following reply:

Hi, thank you for your e-mail. I am sorry you are having an issue with your Muso. There was an update to the Muso a couple of months ago. This 1.8 update added Airplay 2. We have found that some basic routers are not able to handle Airplay 2. Changing the router to better model should solve this. It will also allow the app to see the Muso.

We would recommend getting a router form a known router manufacturer like Netgear, and one from the mid to upper part of their range.

Now I’m back in the UK it works fine with my ASUS router.

Thanks very much for your suggestions everybody.
Although we were not having problems with any broadband connected devices, I decided to reboot the router (BT Hub 6) anyway. I can now connect via AirPlay although it still takes about a minute for Mu-so to appear on the AirPlay drop down list.
Thanks again for help.