Airplay Not working

I am new to the Naim family. I recently purchased a Naim Uniti Nova and I set the unit up everything worked perfectly the first time. Since then I have noticed number of little quirky issues and I am hoping I can find some answers to it.

My WiFi set up is Unifi and it has 3 AP’s in the house. I don’t have a separate 2.4 Ghz and 5Ghz network. I let the USG does the band steering. Having said that I can see that the Nova is connected to the 5Ghz network.
The issues I am facing are ,

  1. Airplay doesn’t work at all. It worked the first day and since then I am unable to do any airplay.
  2. App is not responding. - When the Nova is on Standby mode the Naim App doesn’t seem to find the unit.
  3. Anytime I try to stream from Tidal by default the Naim App is picking up Google Chrome cast and some times the music plays some time it doesn’t.
  4. When I launch Tidal from the Naim App the Audio format doesn’t go to HiFi. It goes to Normal.

I have updated the Firmware on the unit and these little issues are really annoying.
Has anyone come across these issues before?


Ad 1. I recently had the same with my Atom. Unplugging it from power and reconnecting after 10 seconds solved the issue. It took some time for the Atom to come online as Airplay device.

Ad 2. This I notice often as well. Typically the app will not find the Atom at first. Then this ‘error screen’ appears in the app, providing tips on how to solve the issue. At the bottom of that page there is a ‘rescan’ button which then always finds the Atom immediately. I have now turned on the ‘keep connected’ option in the app under ‘other settings’ recently and now it seems to be better and the app immediately finds the Atom. (please not that I use the Dutch version of the app, so the actual English menu options might be different).

@afgverhart Thanks for getting back to me on this one. I will do a power cycle down to see whether that fixes the issue #1.
For issue#2 I have tried the re-scan option as well and it still doesn’t solve the problem.

Personally, i would either turn off one of the networks completely, or rename one with a different password.

@jasons6930 There is only one network.

Either use the 2.4 or the 5 or if not, change the ssid and password on one of them and get rid of band steering.

@jasons6930 that pretty much takes away all the reason why you want to go with these type of setups.

I agree however so far I have yet to find any device that successfully uses it.

It would certainly be something I would try whilst trouble shooting.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.