Anyone else have this Nova /Core glitch? Help with potential playback bug!

I thought I’d throw this one out there because it is an unusual and intermittent issue on my own personal setup, which I am quite able to get sorted but thought I’d pose the question to see whether this may be a software or hardware fault that some of you may have noticed.
I would hasten to add that I have done the usual power down and factory reset courses of action and the problem still occurs.
Here is a description of the problem: when using the Naim app(release or Beta) and streaming locally via my Uniti Core, I get a consistent skip or several skips during playback at around 10 secs before the end of most tracks ripped in FLAC. It’s always around 10 secs before the end of a track, regardless of track length on FLAC files.
The same problem doesn’t occur on tracks I have ripped in WAV. This is something I’ve only recently noticed and it might go undetected in casual listening. The trouble is, once heard you can’t unhear it!
Strangely, the same thing doesn’t occur when using ROON via my Uniti Core and streaming locally with either FLAC or WAV files. It also doesn’t occur when streaming from Qobuz/Spotify/Airplay etc.
This would suggest to me a bug in the uPnp Naim software but I can’t be sure.
Some feedback from the community would be appreciated because I may have discovered a bug that the Naim software department needs to look at.

How are the core and nova connected, do you use a direct connection?

I assume you’ve tried the same flacs on a usb stick shoved into the nova?

Can you remove the Naim app from the equation; eg set up jriver media centre on a pc (you get a free trial for a month), point it at the files on the core (or might be easier to simply copy some flacs to the pc) and set it up as a upnp server. Then using jriver, use “play to” the nova.

In jriver you right click on an album and can send it to an output device:

Everything is connected using wired Ethernet. I have Roon server installed on a Macmini on the same ethernet network and this accesses my Uniti Core/Nova via an Innuos PhoenixNet switch with no playback issues.
The glitch only happens when using the Naim app as described in my earlier post.
I haven’t used the usb input on my Nova since acquiring a Uniti Core, so I will give that a try to see if the glitch is reproducable.

Roon doesn’t work quite like a UPnP server, and it bypasses the buffer in your streamer, so I would be trying a different UPnP server to see if you can eliminate the Core as part of the problem first.
Also maybe try the Core into a different streamer if you have one.

Ok, so I’ve tried accessing my Core via a WiiM streamer using the WiiM app and the files that glitch via the Naim app don’t glitch on the WiiM app. I’m using a separate playback device from my Nova, so I think the Naim app may have a bug.

Are you using the IOS or Android version of the Naim app? And on what device with what version of the OS?

The Naim app is not used for playback of stream music files… it’s not in the circuit as it were… it simply programmes the order of actions the streamer performs, therefore pretty certain that it is irrelevant in this case.
.
If there is a difference in playout between Roon and DLNA, I would first look at your DLNA server, and try an alternate server, and control that via the Naim app.

The Naim app instructs the streamer to directly fetch and load into memory the streamable data from your DLNA server, and this allows the streamer to work optimally with DLNA.

If you use a third party app then it can typically only tell the DLNA server to push the stream to the streamer, not dissimilar to how Roon operates, but is different to how streamer works with the Naim app instructing it.

My guess there is some sort of an interoperability issue between the DLNA server and streamer, perhaps once it has sent the stream data to the streamer and filled its buffer, the DLNA server is signalling the streamer to stop play after a period of time (perhaps why also FLAC is affected and not wav)… not expecting the streamer to have buffered the sound. A network trace on your streamer would confirm, which I guess is not helpful to you, so an alternate is temporarily set up another DLNA server and see if the issues go away… if they don’t it looks like an issue with the streamer.

I believe the Naim app talks directly to the UPnP server when browsing and queuing files to play. (Presumably this is different to 1st gen models as these allowed you to browse using the remote control/front panel display). I can’t pretend to have an in depth understanding of how this works under the hood, but is it not possible that the app is part of the problem here as it is communicating with both server and streamer?

iOS with all the latest firmware and updates.

USB on my Nova works glitch free.

Yes - it essentially gets stream indexing, album group and server location information to pass through to the streamer so it knows which file to queue and request so that it can load into the streamer’s memory. The Naim app also interworks with the server to search for media.

If you like the main active part is between Streamer and server, but the ‘eyes’ as it were are via the Naim app.

This is why the streamer continues to play an album or playlist once loaded into the streamer - once the Naim app is switched off… it has finished programming the streamer what to do.

So acid test… does this early stopping issue still occur when the Naim app switched off? If not then it would be reasonable to assume there is some three way issue - otherwise the app is not relevant.

If you remember in the early days of the first generation streamers had limited memory so could only hold relatively short playlists - that was then upgraded in later first gen streamers, or the there was a streaming board swap out for the very early streamers that were already with customers.

1 Like

Still glitches after shutting down the Naim app.

Cool - so almost certainly nothing to do with the App then. Good you have confirmed.
Can you try a different DLNA server now?

S

So it looks like rebooting the main Fritzbox router has resolved the issue for now. Go figure!
An example of Occam’s Razor??
Apologies for wasting peoples time.