App can't find Uniti Core

I recently purchased a Core however the Naim app can’t find it. I have it hard wired to my router and have tried rebooting the Core and the router. I’ve also taken all other devices off the network but this wasn’t successful either. I have a Nova as well and have no issues with it. I’m not a computer person so would appreciate it if responses aren’t overly technical.

Was this a new Core or a second-hand one?

In either case, have you tried another ethernet cable and another port on your router?


Have you asked for help from your dealer?
I’ve heard of people not checking their routers to only find the port was dead- there were no ‘flashing lights’. Or a bad ethernet cable.
Good luck

Have you “registered “ the core Within the Naim app ?..had a similar problem with our qb…going through the register your product process sorted things out.

You don’t need to register the Core in the app. That process doesn’t apply to the Core at all.



Thanks to you all for your replies and apologies for not including the details you’ve noted. The Core I bought is new and I’ve tried using different ethernet cables and different ports on the modem but this hasn’t made a difference. I use Android devices and have tried both my tablet and my mobile phone but neither can find the Core. I’m in Australia and live on the west coast but purchased the Core from a dealer on the east coast which is why I haven’t followed this up with them. There is a dealer here and I’ll contact them if there aren’t further suggestions that I can try to fix the problem myself.

Sorry…having an off day yesterday…meant to say l solved my connection problem by re - setting the app…hope you get this sorted.
Steve .

Do you know that the Core is in fact working? For example, if you hold the front panel button for a second and let go, does the Core wake up or is it already awake with the light on the bottom strip lit? If you feed a CD into the slot on the front, does it go in, spin up and take a minute or two ripping before ejecting again?

I have an occasional fault on my Core that when you plug it in, the light comes on but nothing happens and it doesn’t appear in the app. What I do is turn the mains power off and immediately on again, in half a second. This kicks it into life. Would be worth giving this a go perhaps.



Hi David,
No, I’m not sure that it’s working, I’ve just assumed that it would being brand new. When I press the power button the logo and eject button light up. When I put a CD in the eject button flashes however there is no noise coming from inside the unit and after a few minutes the CD doesn’t eject but has to be manually ejected. I’ve tried your suggestion of turning the mains power off and on quickly but this doesn’t help. In case it helps, I installed a Seagate 2 GB drive.

It does sound like it is faulty to me. It should rip the CD even if it isn’t seeing an Internet connection. Then it should queue looking for the metadata later when the internet connection is back.

The only other thing I can suggest is a factory reset. I don’t know why you might need to do it what with it being new, but you lose nothing by trying. You do a factory reset by taking the power off, hold in the power/standby button on the front and keep holding it in. Turn the power back on again and keep holding the button in until you see the light by the front panel USB flash. Then you let go the button and it should finish starting within a few seconds. You will need to set the music store to be the internal HDD again. (But since you can’t see it in the app yet, you won’t have been able to do that for the first time yet!)

You could also email the Naim technical support people. They may have other suggestions, but I think I see a visit to your Naim dealer in your imminent future. At least they can quickly power it up and confirm whether or not it works for them.



Get used to problems with App as it is not fit for purpose!! I can’t understand why Naim not even bothers to read this forum maybe they would wake up out of their dreamworld. I bought a NAS in the end and run Asset without any problems. I also bought PerfectTunes to sort the messy tagging and oversized images the Core produces.

Great contribution Bru.

I’m sure we all welcome your very considered, well-balanced, contributions, helping to solve other’s problems with helpful insights as they always do.

1 Like

I’m sorry for dropping out of this thread for so long. I’ve had the Core at the service dealer for 4 weeks now. He’s said that he’s waiting on a response from Naim regarding a software reload.
I’ll let you know what the issue was once it’s resolved.
Thank you all for your help.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.