App visibility of uniti and mu-so

Happy new year everyone
I’ve got an odd one, I think. My uniti nova is connected to my network, it’s streaming internet radio fine, but can’t detect what CD is playing and isn’t visible to my app either. I’ve got a mu-so running as well on an extension of the same network and that’s not being detected either. I’ve reset the router and firmware is all up to date and the app has been reinstalled. So, I think I’ve tried everything you reconnect them but I’ve drawn a blank. Can anyone suggest a plan C?

So the app isn’t seeing either streamer? Or can you see them but not do anything with them?

What are you running the app on? i.e. is it IOS or Android?

Did this use to work but suddenly stopped or has it never worked?

If it suddenly stopped, what changed at around that time?

Hi David
Thanks for the reply.

It’s the Android app, it can’t see either system, we’ve had a bit of work done which added a couple of items to the network (security cameras) but everything works fine. The bit that confused me is why it’s streaming internet radio but can’t lookup CD meta data. They’re both running on wired connection as well.



Can you clarify exactly what music sources you are referring to? When you refer to CDs playing and CD metadata lookup, are you talking about CDs you have ripped, and if so, where are they stored and what server are you running to play them?
I suspect maybe a network setup issue, but hard to say without knowing how it is connected and what network equipment you are running.

Or it could be as simple as when I started out with my Star; the filename of the coverart. When I got my Star, I had already ripped a couple of CD’s on my laptop - Star played them alright but could not show the coverart. Contrary to the Uniti native ripped CD’s later. Turned out the coverart filename needs to be the same for every CD - I posted on that before; ‘coverfront’ I think it was. Not sure though if the Nova treats this ripped CD’s the same way the Star does. Not sure if we’re dealing with ripped CD’s either here?

It’s not as simple as that because the app can’t see either of the streamers at all. I think that adding the security cameras has changed something in the network setup, but as Chris says, it’s hard to know what that could be without knowing much more about what it is and the way it’s all configured.

1 Like

Ah, ok, I missed that visibility aspect

Thank you both for you for your replies. Here’s a summary of where I’ve got to which hopefully answers a couple of the questions raised
*Both systems are on wired internet connections and have been for 4 years. The network hasn’t changed.

  • The Uniti runs off the main network, Mu-So off a slave hub (long story) and both are normally visible and controllable whichever router my phone is connected to
  • The Uniti isn’t pulling through CD art or meta data (Club des Belugas CD playing) and trying another CD (Gregory Porter) it pulled through the album and track name but no art- so I’m not playing the music from a NAS etc. but it’s seeing some info
  • The Uniti is playing internet radio fine
  • I’ve unplugged the Ethernet cable and replugged it
  • The app still isn’t finding either of them
  • Mrs R has an iPhone, the app on there is just scrolling round and I can’t do anything- even the Settings icon just gives me the rotating wheel of gloom

So, it looks as though it’s something to do with the network but no idea why as it’s connected to the same network as our phones.

I’ll see if I can Bluetooth it tomorrow but any thoughts anyone has in the meantime would be most appreciated.

Have a good evening all

This is definitely a network problem. For a start it sounds like the WiFi network that your phones are on is not the same network that the Nova and the muso are on. Also if the Nova can’t see the metadata from the NAS, that’s nothing to do with the app at all.

I wondering what whoever installed your security cameras might have done to your network. For example did they change any router settings?

And presumably you have tried restarting the router? So turn it all off, turn the router off. Wait a couple of minutes and then turn the router on again. When it has fully restarted, turn the other stuff on bit by bit, starting with the slave hub.

Incidentally I assume you don’t actually have two routers? So your slave hub isn’t in router mode? If it is, then that’s probably what’s wrong and your Naim kit might have ip addresses from one router and the phones from the other….

I smell a rat! Can you tell us exactly what this ‘slave hub’ is, and what router you are using?

The rat has always behaved perfectly well! Essentially we have a little building which is out of range for the WiFi in the house. It’s all wired connections from the house, and main web connection, via a BT router. We tried range extenders and they didn’t work so I run a second router in that building to give WiFi connectivity but the wired connection there is essentially an extension of the house. The phone obviously has to work off that WiFi to get access to things like the mu-so but because it’s just a second hub name, it’s the same overrall bunch of internet. I can get brownie points by playing Mrs R’s favourite song on the S*nos in the kitchen when I’m in the other building for example. My NAS sits in that building and I can see that via laptop (ie wired connection) or mobile app so the enforced setup seems to be a red herring in the problem’s cause, but it was with laying out the full story to start with!

Back to the sleuthing…

If your second hub is actually configured as a second router, then there is your problem right there.

Hi David. Fear not, i’s not. It’s running as a slave. It all worked fine until the last upgrade to the firmware of each. I’ll have a prod around later today to see what I can find

So is this device connected to the BT router with an Ethernet cable, as opposed to a Powerline connection which is notorious for causing problems?
Are you sure that this device doesn’t run its own DHCP server rather than running off the one in the main router? This often causes discovery problems. Some devices allow you to disable it, others do not and are therefore best avoided.

Given that you have a BT router you might consider using their WiFi discs which are pretty reliable and will ensure compatibility. Perhaps you already are, but it would help if you said exactly what hardware you are using as this may help someone here to pin down the problem.

Thank you Chris. Full details to follow later, a 6 year old same 2 dogs need a walk! (But, yes, all Ethernet connections)

OK here we go…thanks for bearing with me.
I’ve got BT Broadband, the Home Hub 6 is used by the connection coming into the house.
There are ethernet connection points through the house.
There’s Cat 5e (I think) connection to the other building.
The Mu-So Qb is in that building, wired into the ethernet.
There’s a second Home Hub running as a slave over there, it gives wifi connectivity but seems to be a bit flaky holding an IP address at the mo so my phone struggles to hold connection to that.
The wifi there has worked fine for 4 years, I suspect the wifi has gone wrong.
The Mu-So was tested this evening, it played internet radio no problem so it can see the outside world.
The Uniti Nova is about 5 feet from the HH 6 on the other side of a wall. It is, again, wired. It’s playing internet radio.
I’ve looked at the devices connected to my HH 6 and both of them are (a) shown and (b) shown to be connected.

The problem is that the app isn’t recognising them as being present on the network even though they are and I can see IP and MAC addresses for each on my laptop. As I said earlier I think, the app gives me the option normally to control either one from the phone. Mrs R’s phone gives the same option and is having the same problem as me- she’s iOS, I’m Android so whatever the problem is has a common fault.

any further thoughts would be welcome, I think I can discount the suggestions that have been made before though, unless I’ve missed something obvious. Time for Naim direct I think!

have a good evening

Copying in @Stevesky here, for any insight

Thank you Clare

Unless you have disabled the DHCP server on this second router you are going to have problems. A network needs to have just one of these, allocating IP addresses to all client devices.
If it’s possible to log into the second router and disable the DHCP server that may well solve your problem. If that option is not available I would suggest you replace it with a BT Disc network or similar and use that instead.

Morning Chris
Yes DHCP is disabled on the slave. As I said, the setup worked for 4 years until this last update, or the security camera installation, but they are both connecting to the internet.

As a side note, it’s interesting (I appreciate the exact degree will vary depending on your point of view) that the Android app fires up and then days it can’t see any rooms, would I like to rescan etc. iOS just hangs and offers nothing.