Asset not finding .wav files

Considering moving on from my Uniti Core, and thought I’d give Asset UPnP a try. My ripped CDs (all ripped in .wav via the Uniti Core) are stored on a Synology NAS, so I have installed the Synology version of Asset and successfully directed it to my Core store folder. However, after Asset did a query of the library, it found all of the individual tracks (10k+ of them) but said there were only 56 artists. I dug a bit and discovered it only found artist info for the odd .mp4 and .flac files in the library; none of the .wav files had the artist title listed, though all of the .wav files were visible in the “all titles” folder. I am assuming it has to do with the metadata on the .wav files not fitting the asset file hierarchy or something along those lines, or perhaps Asset is looking for the metadata in some format that the Uniti Core didn’t tag the files with.

I’m sure I’m not the first person to find their entire Uniti Core (or Unitiserve, for that matter) ripped library won’t organize properly in Asset, but I can’t find an answer in the archives. Anyone have a solution?

In cases it matters, I’m using the free version of Asset for Synology at the moment. I’m happy to pay up for the premium version, but want to make sure it will catalog my music properly first.


Not sure but the old Uniti Serve used to store metadata separate from the WAV files. If you ripped them with the Core, it may be they are missing tags needed for Asset (or any other software) to understand the artist, album, track relationship.

If the directory structure is logical enough (like ARTIST/ALBUM/TRACK_NO.TITLE) then something like dbPoweramp has an extension to automatically tag everything. But someone who has moved from Core to Asset may have more experience there.

The Serve does not embed metadata into its wav rips; instead putting them in a packet that sits alongside the files. That’s why Asset can’t see them. The answer is to get the Serve to convert all the files to flac. This is done via the desktop client. Asset will then find them. You set Asset to transcode the flac to wav when you play them, and they will sound exactly the same as the native wavs.

1 Like

To underscore that Asset does see (read) normal WAV files, it can’t read the unique Naim ripped files that are packaged differently as pointed out.

The OP has a Core, which I believe cannot do this. I seem to recall that someone posted here recently that Songkong is the answer.

Silly me! It seems a weird bit of functionality to omit, as a user who has ripped to wav is then very restricted.

Yes, if you look at the Melco site they have a special Songkong for Melco software. They make the point it automatically retrieves metadata and adds or corrects Naim wav files so a Melco can play them.

I wonder if that would also apply to Asset, which isn’t used by Melco so far as I know.

There’s a commercial version of Song Long that will parse Naim metadata also. Asset should read the tags from that just fine.

1 Like

I’ve just looked it up, and see that it costs £99. It’s unfortunate to have to pay that when the UnitiServe would do it for free. That’s progress I suppose.

1 Like

You could try converting them to FLAC using something like dbPoweramp convertor or Free Audio Convertor. This will give you untagged FLAC files.

Then use MusicBrainz Picard to identify and tag the files. This will use the MusicBrainz database and match accoridung to the sound signature. It works pretty well for most albums but can sometimes get into a pickle if the track appears on more than one album, e.g. compilations.

Maybe try on a subset of your collection and see how you go?

You all are most awesome. Thank you for your help. I was hoping this was going to be a simple process but it appears not.

To clarify, the Unitiserve is long gone and I have a Uniti Core now, so I can’t convert the files using the Unitiserve desktop client.

The files are all organized in folders with the hierarchy Artist/Album/Track; it seems that there are software solutions out there that can use this to create metadata tags (after I convert everything to FLAC first). Any recommendations for the simplest software solution to both convert from .wav to .flac and then to create the tags? Also, remember the library is on my Synology so whatever software I use has to work with the files while they’re on the Synology (or, I guess I could copy them over to the PC, but I’d have to buy a new external HD as my PC only has a 1 TB SSD). And yes, I will backup the music folder with the .wav files in it on the Synology before I mess around with converting/tagging in case it all goes to heck.

Thank you again!

I’d try what David suggested in the immediately preceding post.

I think it might be easiest to do this in three steps: copy your existing file structure to a new main branch (eg under /flac); use EAC (Exact Audio Copy) to do the wav to flac conversion in place (note that the easiest / default / only (?)) option for this is a replacement, that at least used to delete the original wav file, hence the copy first suggestion); use mp3tag to auto-tag based on your file folder and naming hierarchy … I have not done this for ages, and now I fear that these main tools may be only for for Windows… but parallel tools exist for Mac (XLD for ripping / format conversions; kid3 or something like that for tag editing)

This is your main advantage, as the tag editors all have string generation capabilities to do this, in the same way that the toppers do it in reverse.

I would create a new test folder hierarchy and do one Artist series first as a trial to get things right with a few albums. You can add album art as you do each set, or maybe you already have the folder.jpg image files in the existing Core hierarchy, which would be ideal.

Good luck, take your time, go in steady chunks and check as you go!

This part works in mp3tag and, iirc, in

Fwiw you shouldn’t have to convert to flac, I’m using tagged wav with asset with no problems. Songkong should just be able to tag the wav files.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.