Bl**dy non-standard CDs

Well, I’m having a rather energetic day today.

I recently bought a couple of used CDs (Matchbox 20 & Joe Cocker) and a couple of days ago I got round to ripping them to my NAS.

Put the first one in the Apple Superdrive, fired up dBpoweramp. Usual metadata appeared on the the screen, and I started a secure rip. Stuck at 1%. After a couple minutes I clicked on cancel and tried to eject the disc. No joy. Tried all sorts of things, but eventually powered off and restarted with my finger on the eject button on the keyboard.

Got out my external LG drive (which I keep for recalcitrant CDs) and tried again. Same story!

My first thought was "b*gger, I’ll have to play the CD and record it onto my KorgM2 then do some tedious editing using Audacity

Picked up the second CD (sorry, can’t remember which order I was using them in!), and that was even worse. The Apple drive wouldn’t eject, and had to go through the rigmarole of forced ejection. Same story with the LG external drive.

So that was 2 rogue CDs. I have since successfully easily ripped another CD just to check. (I keep the CDs in boxes in the loft).

So, 2 “rogue” CDs in a row. Bl**dy annoying.

Currently I have unboxed my Naim CDS (CDPS is heavy), needed to replace one of the "feet on the puck. I’ve had this player since Naim first started making them! Hooked it up to the 552 and it’s currently playing the Joe Cocker while I record it onto the Korg M2. I did think of just using the Oppo 103 as the CD player source, but it was disappointing. Currently recording is Joe Cocker “I Who Have Nothing” - really great guitar solo by Jeff Beck.

The (b)light of my life is demanding that I clear up the Naim boxes immediately. I’m not cooperating. They’re not in the way (on the floor of my study). I’ll pack it all away when I’ve finished the recordings. CDS sounds great, BTW! I’d leave it permanently connected to the rest of the system, but don’t have the space to accommodate it (sigh)

Do the “CDs” have copy protection?

I remember being caught by 1 or 2, years ago, which had Copy Protection (or so the Interwbz told me). Think I just sent them back… ‘CD doesn’t work…’

I had a Blue Nile cd with copy protection which i found had been released by mistake as an early batch. Got my money back as it did not meet cd red book standards……not a cd as such. So they are out there, but rare.

1 Like

I’m really just having a moan. Usually they work OK in the LG drive, but every so often I come across a really awkward one and finish up going the Digital > play and record to Digital route.

The offending albums are :

Joe Cocker - Heart and Soul. This is an EMI CD and is copy protected.

Matchbox 20 - Yourself or Someone Like You. This is a Warner group CD, so I assume it’s protected.

Usually I find that these problem CDs can be ripped by dBpoweramp (using the LG drive) with the Option set to Burst or Defective By Design. However this fails on a few discs. The discs do occasionally make me do a forced power off and restart to eject though. That’s the really annoying thing.

You could try ripping them via iTunes - that can sometimes work.

1 Like

Thinking back, one of mine could have been Blue Nile. I did the same - returned to seller as not working.

1 Like

Tried that. Got the “no CD” message. So, just 2 rogue CDs.

Have the same CD. Out of curiosity,did a secure rip with dbPoweramp,works fine.
Using Windows though.

My iMac is 9 years old. So can’t be upgraded to their newer operating systems. I’ve no intention of replacing it until it either “dies” or stops doing the tasks I want it to do. It may just be that the Mac is more finicky.

I don’t think Macs are “better” than PCs, just a little different. I bought mine because I liked the big screen and was glad to get away from the big Windows PC box which I kept bumping my knee on. The big screen is very useful when using Sibelius Notation Software.

I just mentioned it for completion. Nothing against Apple. :grin:

A while back I had a problem ripping Warner CDs. It was this label


Took me ages to find out the issue - it was something to do (strangely) with the make of the CD ripper mechanism. Tried a few ripper cd drives I had lying around and eventually found one that worked.

s’OK. I didnt’ take it that way. I was just wondering whether it might be a Mac based problem. I still miss my old Acorn Risc Computer. Only moved to Windows PC because of lack of software.

That’s why I still keep my old LG drive as well.

Note that these problems need not be the CDs. And unlikely in the operating system or the application. More likely the firmware in the CD-mechanism. With a computer you use a data-mechanism and the audio part seems to be low priority when it comes to error handling or handling various attempts at copy protection. And many manufacturers sourced the same firmware. With both audio and data CDs in decline no one is willing to invest. I have been tilccThis is in the redbook but no-one bothered until

1 Like

That was probably a TSST Corp. drive (Toshiba/Samsung I think) as I’ve had Warner bothers with those. A swap out for an Asus fixed that.

DBPoweramp publish a chart of drive performance in their support forums, which may help purchasing a good drive (hence my Asus)

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.