Browsing by location on Uniti Core

Hi, looking for advice. On my uniti core, using the naim app I am unable to browse albums by location - neither internal or external HDD. I am confident that the data is there as i can search for a specific album and it becomes visible and plays. Also if I remove the external the data is visible on mac and the internal is visible across the network. The issue seems to be wherever i try to browse via app.
The approach i take is to browse to ‘albums by location’, the two separate drives are shown, however when i click on either drive the ‘waiting’ wheel just spins. I have even resorted to letting it spin for over 2 hrs in the expectation that ‘it just takes time’ however this still does not load. Is this a bug of any recent update as i am certain i could do this several months back when I first purchased the core.
Thanks

I have never tried to do this, nor am I sure I understand why you might want to, but I just discovered that it works ok on my Core.

Have you tried a power-off restart of your Core?

Best

David

I find it a useful feature when browsing music. I store different types of music on each drive. It’s useful feature when browsing music to play.

I have done the usual full power down and reset all networking components.

Well I only have an internal drive, but when I click on that in the search by location option, it populates instantly, so its not that there is a bug in the firmware I think.

Best

David

1 Like

Yes, that’s what I used to get - the instant response. Perhaps a little longer with the external via usb. Thanks for trying anyway. Appreciated. I’ll see if any other suggestions pop up.

It’s pretty standard for UPnP servers generally to merge different locations into a single library. A more conventional way of browsing would be to tag your music by genre etc.

O.K. I’ve tried this as I have a usb backup hd with some music distinct from my internal drive.

In the past when I selected ‘Albums by location’ this usb drive could be seen, selected and played as distinct from the internal one.

Now I can see the drive to be selected, but as yourself the music isn’t showing up.

One thing I did notice, in my case at least, is that if I go to the location ‘Artist’s’ and then scroll to the very bottom, the selections that were not specifically ripped by the Core are segregated here.

So therefore, if I’m interested in considering these albums only at least I know where to find them. Otherwise these same selections are alphabetically intermixed with the Core rips, but harder to peruse as I have over a 1000 rips.

Hope this helps.

I do have the libraries natively merged in the Uniti. Core UPnP, so I am able to access the music. I can search by genre. Conventional browsing is possible, however it was a feature that is shown to be possible and I have found it useful.

I have no experience with the Core, however I am another who likes tge facility to browse by file structure - disk, nested folders etc - ad I use a structured approach to file storage for ease of use, maintenance, etc. Unfortunately too few library/playing programs allow use of this, despite its simplicity, its logical format that is readily tailored to individual preferences, and despite how common such storage is likely to be. When you take into account the inconsistency and lack of completeness of metadata on files as ripped from CDs or downloaded from various sources, the omission of support for file structure browsing is shocking really.

That said, when I had an ND5XS, firstly using NAS running Twonky then Logitech Media Player, and later using a Mac Mini as a NAS with Serviio as UPnP server, the Naim app happily displayed my music by file structure, or at least so it appeared which is all that mattered, which was great. However that was 5 years ago now so no idea if it has changed.