Cannot get V1 Uniti to work with network/apps--at wit's end!

Hello all. I recently purchased an older Uniti for a very low price, with the prviso that the screen did not work (gettig one from the French seller on eBay, so that might help). It is running firmware version, dated 9-26-2008. The firmware update info on the support site says to NOT update firmware if your current version is below 3.0, or if you have the iPod connector, which mine does. I am told the digital board is likely 24/96, and many of the features i need to access require the now-unavailable, 24/192 board.
It plays wonderfully, via analog sources, and I was able to determine which analog inputs are mapped to which input direct-select remote buttons. The cd player works, and the tuner hisses, but I have not yet connected an antenna-not sure how i wuld tune the tuner without the ability to control the Uniti either via display or app control. (see below)

The Uniti is connected to a switch via cat 6e cable, and it is being assigned an IP address by my router, which handles the DHCP. Problem is, neither the ios nor the android apps will control the unit, or even talk to it, other than seeing it when i manually input the IP address. on a windows 10 laptop, the Uniti shows up in my network neighborhood as an audio device, and yet it does not play from any server software i have tried. it actas as-if it should work, but does not play (not sure which input i wold have to select on the Uniti, but if i just slowly cycle through them, nothing seems to happen.
I’d love any ideas anyone might have- the activity leds flash on green on both the switch and the Uniti, the orange LED is constant-on, on the back of the Uniti.

But, darn, thi thing sounds great-just wish it did ‘all the things’ as the young people say (or maybe not-I’m not able to keep up wi the slang any more LOL)

Have you tried a hard reset of the uniti, might be worth a punt?

I think you switch it off at the back then hold in stop and switch it on keep holding for like ten seconds then press play. Someone will tell me if I am wrong.

Nearly right @garyi ! You have to press Mute rather than Play, according to this link here. Mind you that must be with a remote. So maybe it’s Play if you are using just the front panel buttons.

I have a recollection that there were some firmware upgrades that had to be installed sequentially, rather than jumping directly to the latest version.

You may wish to contact Naim support to get better information (and possibly the missing versions to download and install), as I don’t think there were any original generation Uniti devices that couldn’t be brought up to the final firmware release version.

Also note I’m pretty sure the firmware version is only visible from the Naim app or the unit display screen.
What’s visible via the browser interface is the firmware version of the Ethernet card.
Eg my uq2 says 2.0.73.something but it’s on 4.7 firmware.

1 Like

There were at one time, but you can go straight from 3.0 or any later version all the way to 4.8 without installing any intermediate versions.

But with no 192/24 card, he won’t be able to do Spotify or Tidal on this unit, even with the latest firmware.

Surely, the OP should contact Naim support… Rather than be posting here…??


Agreed… but he’s only on a really early version 2.x:

Worth double checking with Support how to go from 2.0 to 3.0, imho

As @robert_h posted, that probably isn’t the firmware version he’s on. But certainly if it is earlier than 3.0, you have to get Naim Support to tell you what to do.

1 Like

Thanks for the kind and thoughtful responses. For some reason, i did not get any notifications otherwise i’d have read them sooner, and replied apace.

I am having no luck finding any 24/192 boards so far, but the screen replacement is on the way. That may have to do, in terms of knowing what settings are set which way… and resort to some Plan-B for streaming. I’ve heard and liked the Uniti Atom, but prefer the sound of the Uniti viz. analog inputs staying in the analog domain. Not giving up yet, but I thnk reaching out to Naim support and getting the scren sorted are the next moves.

Was thining of getting a Stageline phono to connect up to this beastie, but not sure how that would fare. Gotta say, the in-built CD player is superb.

A Stageline would be a good choice with a Uniti. It is supplied with a 5 pin SNAIC lead which you will need to connect it. When buying used, make sure that the seller includes this, otherwise you will have to buy one.

if the firmware is pre v3 then it probably will not work with the current Focal&Naim app. Have you tried the old app “N-serve” which looks like it is still available on the apple store?

N-Serve is for servers, not streamers, so I’m afraid it won’t be any use here.

n-serve will d/l and run, but cannot find server(s). I have twonky running on my ASUS NAS and minim server running on a QNAP NAS. Windows pcs can see the uniti as a music device, and twonky looks like it will play to the Uniti, but does not actually do so.

It may just be that the network ‘board’ is ‘broken’ but it seems like if it can get an IP address, and windows network neighborhood/sharing sees it as a music device means it is not completely dead (to make a Princess Bride reference). BTW, my Netgear router identifies the Uniti as Lenovo device

N-Serve is for Naim servers (Unitiserve, HDX) so I’m afraid it won’t find or control any others.

When you run a UPnP server you need to use the streamer to access it, via either the Naim app or the remote control/front panel display in the case of a Uniti.

I installed the replacement screen yesterday- and it is a joy to use (not so much fun installing it, though). Lacking app control, there were a number of settings that i did not have access to, or even to be able to discern their status. Problem solved!

Looks like the front pnel USB likes FAT32 formatted fash drives, but the menu scrolling is pretty dated. It found some active services in the UPnP setting, but would not play (pull) from them. Running Twonky and Mini server, one on each of my two 4-bay NAS dries allows me to cast to the Uniti (playing now!)
It did not like flac files, but my WAV files play nicely. Don’t yet have a way to play Qobuz and/or Tidal this way, but i do have a Roon endpoint connected analog, for that stuff.

The apps still do not talk to the Uniti, and according to its screen, it does not seem to know it is playing music through the ethernet connection…

The journey continues. Probably goning to try a Stageline phono, and possibly a older 250 amp (a used one that a friend has kindly offereed to loan to me.)

Good to hear you have made some progress. Are you now able to check which firmware version the Uniti is running? Using the remote to look through the Settings menu on the front panel display should find it.

To get the firmware version, you press the spanner or wrench key on the remote, scroll down to Factory Settings, select that, then scroll down to System Status, select that and scroll a long way down to Version which will say something like 4.8.00

forgot to actually send this after I wrote it on Tuewsday!
it says
DPCB: DR 002-001. MR 002-002
BC software I200809260853. (not sure if the leading charcter is a 1 or capita I
CD version 7.05
Version and Boot show 1.1.00

that was all the info on the screen in the factory settings menu

If Version shows then that is unimaginatively old and I’m surprised it works at all. Anyway you will need to contact Naim Support to ask them how you can go about updating the firmware. (Earlier than version 3.0, you have to get their help as per the firmware update instructions.)