Canon Printer failure ☹

Not so long ago I was amazed that a Canon Pixma Pro 9000 Mk II A3+ printer which had not been used for several years was working fine with a normal nozzle check. I have used it several times in recent months and print quality excellent.

My daughter asked me to print a photo to give to a friend but despite being on the printer was not identified by the Mac to which it was connected via USB. This struck me as odd but but it was recognised after I unplugged and reconnected the USB cable at the Mac end.

I printed a nozzle check on the back of one of those PIN notification letters (not really sure why I didn’t use a piece of blank A4) which came out fine as far as I can tell with no evidence of a paper feed issue/jam.

Tried to print a 6x4" borderless photo and got a B200 error from the printer driver saying it would need to be sent to a Canon service centre. Not good. I can see @SamClaus had problems accessing service for a Canon printer, and on checking mine is ‘end of life’ and Canon won’t offer service/repair.

We had a power cut 2 days ago and the printer would have been on at the time. Had the printhead not parked properly or could the power cut have damaged the circuitry?

Did I cause a problem using that PIN letter to do the nozzle check? Seems unlikely.

Maybe it was unplugging/reconnecting the USB cable with the printer still on but why did it allow me to run a nozzle check using the printer utility?

It’s just annoying as I still have plenty of new ink cartridges for it, and while it could be a catastrophic fault it might be something trivial.

It looks like a nightmare to disassemble it but I want to try to access the printhead, though I don’t think replacements are available.


Sorry, it’s boring I know.

Things fail.

I see the Canon guidance is:

B200 - This could also be displayed as P10 or the orange and green light blinking 10 times


B200 is a service error that can occur due to a hardware failure with either the printer or the print head.


In most instances, a B200 error will require a repair at a Canon authorised repair centre, however prior to sending your printer for repair please follow the steps below to try and resolve this error-

  1. Turn off the printer
  2. Disconnect the power cable
  3. Open the printer cover
  4. Check for any orange protective tape or white polystyrene and remove if necessary
  5. Check that there are no foreign objects in the printer (such as a paper clip) and remove if necessary
  6. Close the cover
  7. Reconnect and turn on

I think for a printer that has been sitting around for a while this may mean that things just need freeing up a bit, wiping sliding parts with lubricant etc.

1 Like

Thanks David, I’ve been browsing most of the evening looking for causes/possible solutions.

It is indeed the 10 alternating green/orange blink error which is a ‘service error’ rather than something potentially fixed by the user.

I found a ‘service manual’ online which helped me get the plastic casing off with only one minor breakage of a plastic tab (no screws at all) - this allowed me to access the carriage/printhead assembly which was firmly parked to the right under the casing.

After removing the printhead and inks I managed to move the ‘carriage’ to ensure it was not obstructed by paper/debris/foreign body then reinstalled the printhead.

Still no go unfortunately.

I suspect the printhead has died, but it could be the logic board or both, and parts are not available unless you cannibalise a used one.

As I mentioned it’s had a good innings but I bought lots of ink/paper whenever they were on offer and the ink at least is a waste as are 75% of the near full cartridges installed.

The problem is, Canon don’t have a network of approved agents - unlike Epson. On the continent you have to send the printer, in its original box, to a service centre near Paris - and the box should on no account be upside down at any one point, which you cannot possibly guarantee.
I managed to sell the ink and the cartridges which I’d installed, which were almost full; I got a good price for them.
I eventually bought another Canon (Prograf 300), as the friendly shop where I buy my photographic equipment does not do Epson… The results are good.

I was tempted to get the Canon A2 (I forget what it’s called), as most professionals claim it’s more reliable, and can be serviced more easily - but it’ an enormous beast.

1 Like

Print heads can be bought from EBay. Alternatively you can clean them up (carefully) which may solve the issue. When I had a Canon I followed various Youtube videos to remove and replace the printhead. It got a few more months use out of it at least


I have had numerous Epson/Canon printers since the early days of digital photography and they all have their pros and cons.

The Epsons were always prone to clogging and wasted ink with repeated cleaning cycles, something which was rare with the Canon printheads which had the advantage of being user replaceable.

Epson dye ink had far better longevity however and I have many badly faded Canon prints.

A non-photo grade Epson EcoTank printer has been brilliant for many years and I’ve not even used the second set of inks I bought for around £40.

As a hobbyist consumables are not something I can offset as a commercial expense, so if there is a good ‘continuous ink system’ from Epson/Canon, preferably with pigment inks that would be ideal.

1 Like

Most of the items I found on ebay were pre-owned printheads not new and you then have no idea if they were used with OEM or aftermarket ink.

The specific error according to the service manual is an irregular voltage from the printhead, so not blocked as such but might be due to electricalprinthead failure or other components/logic board upstream.

I’m quite suspicious that it was the unexpected power cut a few days ago that caused the problem, but it may just be random component failure today.

I have a Canon Pixma Pro 9000II as well. I read this with horror and dread. It is an excellent machine and I have a set and a half of inks as I recently purchased a set of 8 inks. The company that supplied the ink phoned to tell me that Canon will no longer sell the cheaper sets of 8 - about £80, they will be selling ink individually, which will be over £100. I have a feeling that they may have an office in Japan somewhere with rows of buttons called ‘ping.’ When they want to remove a model from their lineup and stop servicing them, they go to the office, find the model button and press ‘ping.’ Within a month all of those machines will die a non-serviceable death and you will have to buy a replacement.
I feel your pain.

1 Like

I am not sure where you are based but, if in the UK, you could try CRC in Woking who I have used for Canon printer repairs in the past. Friendly and helpful.

1 Like

It’s just frustrating as it was such a sudden event immediately after a normal nozzle check.

The Photo Cyan ink is low but nothing else.

The error itself is unfortunately rather vague and I think even if parts were available I think it would be a gamble that the printhead itself is to blame.

1 Like

I hadn’t heard of CRC before but I see that they have a mightily convincing website so very useful to know!

1 Like

Thanks for that, I came across their site last night no printheads available unfortunately - I suspect it won’t be economical to repair even if they’d take a look but no harm asking them.

I’m in Wales and a trip there would be just under 3 hours in the car so not impossible and they seem to offer a while you wait service.

I’m suspicious the power cut stressed something but it may be one of those things. I think if I’d killed the rear USB input the printer driver wouldn’t be able to report the B200 fault at all and would just say it wasn’t connected.

Thinking about it the printhead/carriage assembly don’t do anything when I power up the printer or manually move the carriage to ink cartridge change position (no LEDs lit by the cartridges). It could be something that actually powers the printhead I suppose. Must check the ribbon cables are well seated.

Just in case you need it (I hope not), I found the service manual here:

1 Like

I assume you’ve tried this sort of stuff?

1 Like

Thanks Matthewjb, I’ve not encountered that specific video but there are numerous possible solutions to try out there, that one included.

The B200 error seems to have several possible causes, it’s a shame the error codes can’t be more specific.

Normally when the printer is turned on the printhead assembly moves and there’s a bit of a cleaning cycle too I think.

When I turn it on there’s no movement at all, so I’ve had to take the external casing off which leaves it in a case open state as though you are going to replace inks but still no carriage movement.

I removed the printhead and inks and powering on again I got some motor activity and the carriage moved to the ink change position, so that probably at least rules out a major power supply issue. I did some gentle cleaning of ink from the printhead without actually touching the nozzles and replaced the cartridges including a new PC one which was low as well as cleaning the printhead contacts with some isopropanol. Unfortunately with printhead/inks in situ nothing happens again on power on which suggests to me a printhead issue - either failure or a clog it is recognising but odd I got a normal nozzle check. Going to give it some time powered down with the new cartridge in place and see what happens. A real shame new printheads aren’t available anymore, and I’m a bit baffled why I didn’t buy one some years ago. At some stage I’ll probably decide to rinse the printhead with water/isopropanol to see if it’ll clear the error - I’ve done this with Canon printheads in the past but only when I’ve had a spare!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.