CD Stuck in Uniti Star

I was ripping a CD on my Uniti Star and the CD would not eject at the end of the process. I tried the paper clip ‘fix’ but it didn’t work. The CD playback screen indicates ‘No CD’ . . . but the darned thing is in there! Any advice on how I might eject the CD would be very much appreciated. Thanks.

I had a similar event in my Core the other week…I actually find the paper clip trigger very rarely seems to instantly spit out a CD…!

I presume you have repeatedly tried…?

When one particular CD got stuck in mine, and had repeatedly tried the paper clip hole, I was beginning to think that was it, was going to have to be serviced……but I then tried powering down the Core, waited a min or two….then turned back on….CD mechanism made a noise or two like it had rediscovered life……I then pressed the normal CD eject button and it magically spat out the disc…! :roll_eyes:

1 Like

Also assuming the Star is like the Core, which I believe it is, the eject pin hole doesn’t trigger a motorised eject. You have to push really hard and it mechanically ejects the CD, taking three or four hard pushes to get it to come out enough for you to grab it.

With the Core I was advised by Naim’s beta test people to take the power off the Core before attempting the manual release (but I had already done it with the power on, so I’m not sure what that was about).

It should eject any CD on power up after the power has been off, but if it doesn’t then that is what the eject pinhole is for.

1 Like

I actually didn’t know that…!
I presumed I was pressing an internal button, this triggering a motorised eject (much like other CD Rom drives, PCs etc) and was trying to be careful at that whilst doing it………No wonder it wasn’t ejecting then…! :roll_eyes: Not sure a bent paper clip has enough umph in it actually…!
Think this little bit of info might be worth Naim adding to the user instructions, mentions nothing about it being mechanical and requiring a decent push……

Thanks for that David. :+1:


Only once has my Unitiserve failed to eject a CD, and like David, I found that several firm pushes with a paper clip were required to budge it.

Thanks to all for your suggestions. The ‘wait-and-see’ approach seemed to work. When I switched-on the machine today, the CD miraculously appeared! I’m not sure why the paper clip strategy didn’t work yesterday . . . I definitely gave it a few very firm pokes.

However, as the stuck CD occured during my first ever attempt at ripping a CD, I am rather nervous about trying it again! Thanks again for everyone’s suggestions.

Don’t be nervous. It’s not an issue that I have heard a lot about so it’s probably a one off. In any case disconnecting the power, leaving it a minute and turning the power on again should make it chuck out a CD.

Dream on! The latest efforts at “user manuals” are pretty worthless - glorified “what’s in the box” and “connections” guides!

1 Like

I’ve had my Star 3 years and used the cd player a lot and it’s never stuck so don’t worry .

Good advice re getting the CD out, but when it keeps happening with differnt good condition disks?

Any advice?

Hi Jam-Inn (I have to say a very appropriate user name for this discussion!) I don’t have any advice beyond the suggestions already made by those who responded to my original post. My main take-away is to try the paper-clip fix and if that doesn’t work, unplug the unit and grab a beer. . . . then try again in the morning. It ain’t rocket science but it worked for me!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.