CDX2-2 collected today and not working

I collected today a preowned CDX2 at LASA service centre. It was there for a fading display, not he Naim logo. I collected the player and later, the rest,at home of the bloke Who consigned It there, including the link plug.
In first instance, i noticed that the inner part with pins, Is rotating inside It’ s plastic enclosure, pretty odd to me. Then, once turned on, the Naim logo Is illuminated but the display and the mech, are absolutely dead

Sounds like a bad link plug (?)

It’ s plausible, however i’ m getting tired with this sort of annoyance

I assume you didn’t turn it on and try it before buying, however perfunctorily?

Have you got back to the seller to query/discuss/seek solution?

As i said, i collected this at the service office and later the package with plug, assuming that everything was fine. I will try a plug from another CDX2 i have

It was actually the plug. I tried another plug and It worked. At the end i unscrewed the core from its case and tightened again, fortunately iIt works now


So in the end LASA service centre has no fault in this. Independent of your personal feelings for the guy who sold you the CDX2, it belonged to a former (dead) owner on behalf of whom the guy was selling it, who used it with an XPS2 and possibly wasn’t aware of the plug’s defect - minor one, by the way, if it was enough to open and close it to solve the issue.
So perhaps the seller isn’t a ‘scoundrel’ after all, but just a guy who hasn’t checked everything very carefully…


I don’t mean to involve LASA and translation of which i meant was not correct perhaps

All is well what ends well.

1 Like

It could have ended well earlier, and without contempt for the seller.


You are free to not buy any further Naim items.

Your Choice.

Possible in the future. Thank you for your previous advice btw.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.