Change ethernet address on NDX2

I have a new router/provider. I previously set the router to 192.168.1.x so for the ndx2 it was/is set to 192.168.1.4 wired (I prefer to use static IP addresses) . I have decided to use the standard 192.168.0.x. range with the new router. The front menu /settings/network settings shows 192.168.1.4 and a wired connection but if I select the network setup option it simply shows wired - no option to change that address. I have disconnected the Lan cable and use wi-fi that picks up a dhcp address no problem but I want to use wired. Sure it’s easy but how do I change that ethernet address?

thanks

If you have already enabled DHCP then plugging in the network cable should work fine.
Why do you want a static IP address? As you have switched to Virgin the DNS will have changed, DHCP ensures everything works properly.

The router dishes out dhcp addresses. With the older router I reserved 192.168.1.2-10 and used them for my wired items like TV so NDX2 must have been set to 192.168.1.4 somewhere. With this router I’m just leaving it at defaults to give dhcp from 192.168.0.2-254. As I said if I disconnect the ethernet cable and enter wi-fi password it picks up an address of 192.168.0.7 or something all good. But plug the ethernet back in and whilst it show wired with a tick the address is still listed as 192.168.1.4 so it’s not picking up a new dhcp address and I can’t see anywhere to put it in manually or not. It doesn’t show in the app so I’m using the ndx front panel. With my Muso I just power off and on and it picked up new dhcp via ethernet cabled without issue (I have powered ndx2 off and on couple of times also)

The address can not be entered into the client, client does not wether it is fixed or DHCP.
Power down , power off router, connect NDX2 Ethernet , power on router, power on NDX2.
Everything should now work

Have done rebooted router and ndx-2 but still set on 192.168.1.4

I must be going mad - I thought I previously set it via the Naim app on my phone but because the phone is now picking up new dhcp wi-fi address it obviously can’t see the ndx-2 in rooms

Must be me ! - I’ll do some more digging

Did a factory reset and picked up new address so ok now

1 Like

Have you tried going to Settings/Other settings/Network in the Naim app and checking the DHCP toggle for wired settings?

Apologies if you have already tried this.

Gah! Too late. See you have already solved it.

If you really want to fix an IP address type the current IP address into a web browser. Then go to Network > Advanced Settings, untick Use DHCP, and enter the network settings you want to use instead. Personally I would recommend that you don’t do this. In a properly functioning LAN it shouldn’t be necessary, but the option is there.

Yes, you’re right Chris, but I only see that now in the app - it isn’t on the unit menu as far as I can see So I must have previously unticked the dhcp box from the app and manually set my “static” address. So with no front panel option to set the new address manually I had to do a factory reset. Perhaps that could be considered as a future improvement by Naim?

You can’t adjust these settings in the app or the front screen settings, I suspect because Naim want to discourage people from using them unless they really need to. You can only view them.
If you didn’t adjust these settings in a web browser perhaps you allocated an IP address to the NDX2 in your router’s DHCP server menu?

1 Like