Chromecast not working

I have a Uniti Star and have been able to use Chromecast without issue until now. In the settings on the NAIM app it shows as input enable so I’m guessing this should be OK, yet the Chromecast icon seems to have disappeared from the app.
Anyway, I usually use Chromecast for both Qobuz and BBC Sounds. Now, when I try to connect the chromecast symbol is there for me to cast to the Uniti Star. I click on Cast to, it then just runs continually on “connecting” but doesn’t actually connect. This is the same for both BBC Sounds and Qobuz?
Thinking of giving up on this, but believe Chromecast is superior in sound to Bluetooth.

I’ve just tried it with the Qobuz App and my Atom and it works fine. I just tapped the Chromecast icon at top right in the Qobuz app, selected the Atom and it played.

I am wondering though, why you’re going through Chromecast rather than using the app directly.


For me, trying to use Chromecast through the Qobuz app it just comes with the message connecting and just stays on that.
However, I agree with you and I do tend to use the NAIM app the majority of the time, and can access everything fine through it including Qobuz. I just like to try and use Chromecast occasionally more to ensure everything runs fine through my Uniti Star. It’s never been an issue before but as you say the NAIM app I find is very good in itself, so don’t really need to use either Chromecast or Bluetooth.

Understood and it’s good to experiment. I guess the next thing to try is rebooting everything, but you’ve probably tried that. If all Chromecast-enabled apps encounter the same problem, perhaps flagging the issue with Naim might be worthwhile.


Further to corres on the subject of Chromecast, I tried through my Dell laptop and there was no issue. My partner also tried with her Apple Iphone, again no problems, so I believe the issue lies with my own Samsung smartphone. It recently had a system upgrade so I’m guessing whatever Samsung did has somehow botched its ability to connect via Chromecast. I did as you suggest reboot without success.
I did see on the Internet something about Android phones needing to have the Google Home App to be able to Chromecast but, up until now, it hasn’t been an issue.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.