Chromecast streaming buffering issue on Uniti Nova

Hey everyone, has anyone else run into a problem starting up a Chromecast stream (I’m trying to use Soundcloud and casting to the Naim Uniti Nova). The issue is, it starts up but then just stays stuck on the same second of audio, often looping for ten seconds or more, until it properly gets going. Once it gets going, moving to another part of the track (scrubbing), causes the same symptoms. If I instead pause playback on my soundcloud app on the phone, and wait maybe five to ten seconds, and press play again, it often plays fine.

But the buffering issue is constant. It makes it really unpleasant to use the built-in chromecast audio. I’m resorting to Airplay 2, which is unfortunate because it means my phone needs to be present and in range and it drains my battery.

Intrigued by your query, I downloaded the Soundcloud App to my iPad and started playing a track. Then tapped the Chromecast icon to stream through the Atom. It worked faultlessly – listening right now – no buffering or any other interruptions. I think the streaming section of the Atom is very similar if not identical to the Nova, so it looks unlikely that there’s an intrinsic problem chromecasting to the Nova. I guess the usual advice applies: reboot the router and the Nova. If that doesn’t solve the problem, raise it with Naim.


That’s curious. It works faultlessly for me with Airplay. Chromecast is absolutely terrible. I have not tried audio sources other than soundcloud though. It’s really just an issue when you initiate the stream or scrub forward or back.

The router is definitely fine, in fact the Nova is not even plugged into the router, it’s plugged straight into an ethernet jack which is connected to my fibre router for the whole apartment. And I’ve rebooted the Nova and power cycled it many times. Very odd, as I didn’t notice this early on, but it’s been a problem for months.

I’m not sure I understand exactly what you’re doing here, but if your router is also your DHCP server, I’m not sure that bypassing it is a good idea. Can you try connecting to a port on your router, then restart everything and see if it improves things.

The Nova is plugged into a jack which is connected via cat6 cable to a fibre router in the closet which also does DHCP for me.

Chromecast works perfectly to my Chromecast Ultra device connected to my TV. It’s just the Nova that exhibits the buffering.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.