Connecting the NDX 2 with RCA plug instead of din

Hello,

I need some advice, about connecting my NDX 2 with the 282 preamp with RCA instead of din din.

I want to experiment with some different high quality RCA cables. But when I connect The RCA cable, I do not get any sound. I have tried to find some information through the manual, but was not able to find it.

Does somebody have experience with this issue, and is able to explain?

Thank you very much

If you go into settings on the Naim app, you will find an audio settings or outputs settings option - sorry I can’t remember exactly what it’s called - that enables you to choose Din or RCA phono. Switch it to RCA and you are good to go.

1 Like

I feel very stupid. I am busy for many hours to figure it out. If I go to the Naim app, I only see 4 digital outputs. Can not find anything that enables me to switch from digital to rca, or something where I can figure out how to change it. On the remote, looking at the manual, wich I read 5 times, I only see input, and no output.

In the app, you select the NDX2, then output settings, and select RCA. Follow the manual instructions for the 282 and remember to exit program mode. I’ve tried RCA when the relay failed on the NDX2 DIN output. I found the DIN output on the NDX2 to be quite significantly better over RCA.

1 Like

It’s not on the remote. It’s in the app. You need to switch the output from analogue Din to RCA phono. I don’t have my NDX2 any more, so cannot say exactly which setting it is. Think it’s called ‘output settings’.

Hi Robert,

On the remote I only see an input button (left above), wich enable my to go to 4 different digital outputs. Same goes, if I try to change something from the Naim app. I have read the manual several times and can not find it, although it should be there.

I have a din connection of an chord signature alray. But now am able to try a chord chordmusic rca. I want to hear what the many times higher range of Chord does to the system

Found it. Thank you very much for your help

Found it, thanks a lot for helping me

Found it, thank you very much for helping me

1 Like

Excellent, glad you sorted it out.

Excellent. Now for your next challenge - selecting the phono input on your 282. This is how it’s done…

1 Like

Funny story - when we got our 252 we presumed it would be set to DIN inputs as that was the “naim preferred” connection method.

Cue much gnashing of teeth as it was set to RCA and there was no sound. Only considered this after unracking entire system, reracking, checking all connections. Two hours of my life, under duress thinking our 252 was bust, which I’ll never get back.

Only upside was I think I dressed the cables better second time around :laughing:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.