Connection issue

Help please!

Hardwired to router in living room is my NDX. Also hardwired into the router is an extender to the kitchen as the walls are to thick for wireless signal.

Hardwired into extender in the kitchen is a Muso

No problem streaming from the Muso (the NDX also shows up) but when I want to stream to NDX from living room it can’t find it. I have to take the iPad to the kitchen and connect it in there before it works.

Any way to connect directly in the living room?

I’ve rebooted everything many times!

I used to have the same problem with wi-fi not reaching the music room at the back of the house.

I tried extenders, which didn’t cure things, besides which, they introduce all sorts of noise onto your mains.

I’ve ended up with an Apple AirPort Extreme base station wired into the router, and an Apple Airport in the music room, hooked into a Cisco network switch, which is directly connected to the router via a long ethernet cable running through the loft.

I’d suggest considering if you can borrow the two bits of Apple kit, to see if this resolves things, and if so, they’re both available for not much at all over on Fleabay.

What exactly is this ‘extender’? If it’s some sort of ‘Ethernet over mains’ device, is it creating its own network, which effectively means that your two streamers are on different networks, therefore not discoverable at the same time?

Extender May be the wrong word! It is not internet over mains as it is connected into router by cat 5 cable. I think it’s called a switch??

OK, that’s probably a good thing! If you can post a photo of it, or the make and model number, that might help.

I’m not too tech savvy!
It’s a TPLink

Please ensure that both NDX and Muso are on the latest firmware. At some stage, before software upgrades, multiroom between the older ND-platform and new platform would not work properly.

Muso is, NDX needs updating to latest, it is one behind. I wii update thank you.

I also think that multi-room with sampling rates higher than 48kHz is still not resolved yet.

You don’t need to update the NDX if it’s only one firmware behind because that doesn’t affect this problem you have at all.


So the TPLink device is capable of performing all of the functions that your main internet router is doing, and I suspect that it needs to be configured properly so that it only acts as a range extender. If you can use a computer to log into it and look at its settings, you should be able to do that.
For starters, type into a web browser, and see if that finds the TPLink. If asked for a user name and password, they will both be ‘admin’ as shown in your photo, unless they have been changed by you or another user.
I haven’t used TPLink devices myself, but somewhere in the settings, you might see the option to turn on Bridge Mode, which should be enabled.
Then look at the wireless settings. You should see options to join or extend an existing network, or create a new one. This may seem counterintuitive, but you want to create a new wireless network, but it is essential that you give it a name and password that is identical to those used for the WiFi from your main router.
Once you’ve done this, turn off both routers and everything that is connected to them. Restart the main router, then all other devices, one at a time. Fingers crossed, this might solve your issue!

Hi Chris
Thanks for the reply. It was configured by our IT guy at work who no longer works for us so I guess it was configured correctly (as he knew what I required)

the only thing I note from your reply is that he did create a new wireless network but he gave it a different name & password to the main router.

It has been working fine for 6 months, just stopped in the last couple of weeks. Any ideas please? I am not very IT savvy!!

If it has worked in the past, maybe something like an IP address conflict? You could try a full network reset…
Delete Naim app from iPad
Turn off every device on your network, wired or wireless, including both routers. Leave it alone for a few minutes.
Restart your router, and wait until it is fully up and running.
Restart the TPLink
Restart the NDX, Muso and iPad
Reload the Naim app
Then see what happens

A useful diagnostic tool for situations like this is an app called Net Analyzer. Preferably the paid version, it’s not that expensive. Use this to scan your network, and it will show you a list of all connected devices and their status and IP address. This may be useful in showing what devices are doing, Bonjour discovery, etc.

If this doesn’t work, and you are willing to spend a little money, you may find that two (or three) mesh WiFi routers (in my case Google) reach the parts others cannot. This can create an additional Wifi home network exclusively for hifi if desired.

Thank you for the suggestions I will try a full reset tonight.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.