Constantly purple light on my MuSo Qb 2

Hi, I have read a lot about the issues about the last update, but I don’t know if my issue is about that update.
My speaker only shows a constant purple light when I try to take my speaker to factory settings. It is not possible to make it show other collars.
I have tried to delete the app, restarted my router, tried to make the app find my rooms, tried to reinstalling the speaker. Now I have no clue what the problem is.
Anybody can help me?
Thanks in advance.
Kindly regard’s Anders.

Have you tried turning the unit off for a few minutes and also using a pin in the reset hole?

Hi thanks for the reply. Yes I have tried to reset the speaker with the pinhole also, but it always turns purple and not flashing.

From the manual.
Illumination Network and Functional State
Off Deep sleep/off
White Network connected
Orange No network
Orange (flashing) Network connection starting
*Purple Wireless connection configured *

  • but network not found*
    Purple (flashing) Wireless setup mode
    *Blue Firmware update underway or *
  • unit in recovery mode*
    *Red (flashing) System fault or amplifier overload *
  • (contact your retailer or Mu-so *
  • support)*

It would look like that your Mu-So can’t find the Wireless network. Do you have any mesh devices, repeaters, or extenders.

The meaning of the purple is maybe not quite clear in your quote from the manual, maybe this makes it clearer:

Which would indeed mean that the wifi network was not found, as you wrote. (Constant purple light)

Thank you both, I have now wired the speaker directly to the router and restarted the speaker and tried the pinhole as well, but it will only show the purple light without flashing.
I have read the manual as well, but it does not make sense that the speaker only shows the purple light without flashing.
The speaker has not worked for almost a month now and I am really missing it to work.

It’s best to email and bring considerable patience, or call them on
T: +44 (0) 1722 443405
Hours of service are Mon-Fri 9:30am-5:30pm GMT/BST

1 Like

Thanks again for your help. I have tried and I got an auto reply but not a solution I could use. I think I have to wait for the new software.
Thank for trying to help.

They will get back to you after the autoreply, but it will take time, maybe weeks. A call seems to be the quicker solution by all accounts :slight_smile:
Good luck, unfortunately I have no other idea

Do you have a Naim dealer within acceptable travelling time?

Hey Guinnless, yes I have one not that far? Can they do other tricks that I cannot do from home?

They should have plenty of experience and knowledge. :slightly_smiling_face:

How long did you press the reset button for?
You need to press it for about 10 seconds.

If your dealer is not far from you then I would contact them and ask for help - that is what they’re there for. Note that the Mu-So and your App device will both need to be connected to the same network. Also make sure they’re working on the same network frequency.

1 Like

Been struggling with mine for some time now and I do not think you need to get the purple led flashing to connect to the router with a network cable. During the setup you give the pin hole a single click, and activate the flashing purple led when setting up the wifi connection. Mine connected automatically when connecting to the router on cable.

Looks like you are Norwegian like me. Mine started malfunction when I tried to update to a new firmware. I bought mine at Oslo Hifi Centre. I have not contacted them yet as I have sent the support at Naim in UK a mail on monday more than a week ago and will wait for that reply first.

Maybe Naim can give us a tip on a service partner in Norway ? Frankly I doubt OHC can give me better help than I can get here, but might be wrong on that :grinning:

This is correct but @Andersvedel did not say anything about connecting it with a network cable :slight_smile: so the assumption was that it’s trying to get a wifi connection and is failing.

You are making a good point - he should try with a cable, even if only temporarily, to see if it works then

He said this. For the record, I have contacted Oslo Hifi Centre regarding the problem I have, and may be Anders having a similar problem, if they can help.

Ah, I missed that part, had only looked at the older posts earlier. Thanks for the correction

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.