Disabling Bluetooth/Spotify Muso

Hi Guys,

for some reason, SPotify has been randomly playing on my muso.

Is there any way to delete the app from the naim app, or to disable Bluetooth on the muso?

I cant even find how to change the password for the bluetooth connection in the Muso App

Cheers

This will be because someone who has connected to your Qb in your house is now using Spotify elsewhere and is casting to your Qb. It’s the way Spotify works. The answer is to ask them to stop. You can set Bluetooth to secure via the Bluetooth input on the app.

Adding to what HH said, if you can’t contact whoever it is or you don’t think that is correct because you don’t think anyone ever connected to your muso, you can remove the association with someone else’s Spotify account by doing a factory reset of your muso. That will resolve the problem, but you will need to reconnect it to your WiFi if that is how you connect it to your home network.

Best

David

Thanks.

I have reset the Muso and so far so good.

It happened again last night when it was only me here and i dont even have an account!

What i find odd, is why the hell would anyone want to connect to a BT speaker if they arent even in earshot of it??

I also think Naim should give us the option of removing apps like this and Tidal from the system if they are not required.

The assumption is that if someone has connected to it in the past and it’s in their list of available players, then sometimes it will get selected by mistake or defaulted to or something like that. It’s not a Naim thing, but rather a Spotify thing. It’s just how they do it. There isn’t anything Naim can do to stop it happening.

Best
David

Yes i understand the reasoning behind it and agree, but to allow it to connect to a speaker when it’s no longer on the same network is a bloody stupid idea, as the app also defaults to the speaker it was connected to last, regardless of where the device is in the world.

To get around this issue, I set the source to anything other than Spotify. It really is Spotify’s issue, not Naim’s.

Nick

Yes indeed, and i’m not really blaming Naim as such, but why Spotify would allow connection to a ‘remote’ speaker when you are nowhere near it to listen to it!

It could easily be stored in the app itself, and not be made available until the device has reconnected to the relevant network.

How is Spotify supposed to know “the relevant network”? You could easily have moved your WiFi speaker (Naim or otherwise) on to a different network, for example if you are travelling for work or you took it to a mate’s for an evening or are on holiday…

Best

David

Naim and Apple seem to manage it via AirPlay I guess?

FFS.

I decided to change the room names on both units, and now, occasionally, ill open the App and they will both revert back to what they were called before!

I thought it might have been me, but it appears to be the Naim app.

You can’t conclude that it’s the Naim app because half the software involved is in the muso, so it could be the muso firmware. anyway you should report it to Naim support because that’s the only way it will get fixed.

Best

David

The Spotify app contains an option to ‘only see local devices’, but this is disabled by default. If you enable it on your device then you only see devices on the local network that you’re connected to. I don’t know why it’s disabled by default, and I don’t understand why they allow you to even connect to remote devices. Seems like an exploitable flaw to me.

1 Like

Hi,

As JSaville mentioned, enabling ‘Show local devices only’ should resolve this issue. This can be found in Spotify settings > devices.

From the Naim APP I also recommend you go into settings > Input Settings > Spotify, from here you should be able to logout the user who is logged in to your Mu-So.

Once you have logged out the person who is using Spotify on your Mu-So, the only way they can log back in is to be on your LAN again.

Regards
Roland

1 Like

Bit of an update,

It appears Spotify has been hacked and a few people have been complaining of random outbursts of music from their bluetooth speakers.

And, as usual, Spotify aren’t really doing much about it.