Download folder problem

After the latest big Windows 10 update (1903) it is not possible to drag files to the download folder anymore. This is to UnitiServe.
Anybody experienced the problem?

I think you have to re-enable the SMB1 service in Windows 10 on your PC because it was disabled by that Microsoft update as a security measure. You can find instructions on how to do that if you google it.


Sorry David.
I did this but it did not help.
Any more suggestions?
Roll back to the previous version of W10.

I think you have to restart everything. So turn all power for both Core and your streamer off, also the router and your PC. Then reboot the router and when it’s settled you can restart the Core. When that is settled then restart your PC and also your streamer. You should be able to see the downloads folder and you should be able to connect to it with your PC.

This seems a bit of a faff. I routinely enable & disable SMB on my Synology NAS, its a simple ‘check box’, no power cycling required.
Windows 10 SMB is untouched & always enabled
Does the UnitiServe not have SMB access in its GUI ??

David was right. The SMB was disabled.
I have never heard about this before.
I turned it on and will power down my router and NDS tom…
So i hope it works again.

As I understand it, the Unitiserve needs SMB and there is no means to disable it in the Unitiserve GUI. Also true of UnitiCore.

OK, I understand, albeit I haven’t got a UnitiServe (only worked with one that belonged to a mate)

However I have not made the point I had in mind when I posted before (rushing to do other things)
I said Windows 10 SMB is untouched & always enabled, what I meant to make clear was that it had the 1903 update last week & it did not disable SMB.

I think I read on the forum a couple of months ago that a recent Windows 10 update had disabled SMB and a mate of mine discussed with me at the time that his Windows 10 PC couldn’t see his Core anymore although his MacBook Pro could.

Re-enabling SMB worked for him after he had restarted everything.



Just use Apple Mac - it works :slight_smile:

Hi Gents,

Just to clarify a few facts here.

The Unitiserve, HDX and Naimnet variants are based on Windows XPE. That operating system used SMB1 only to network share content.

Over the years SMB2, SMB3.x came out which added extra functionality, improved security and overall moved with the expectations for modern networking. See:

In a Windows 10 update release, Microsoft decided to disable SMB1 support for some user types, meaning Windows XP(E) devices could no longer communicate. However, while XP(E) was supported they never updated the networking stacks to offer SMB2 or above. Checkmate!

For details on how to re-enable SMB1:

On Uniti Core + products like Uniti Star we support SMB1,2.x and 3.x via the libraries.


Steve Harris
Software Director

1 Like

Thank you, Steve.
I opened the link and did this. And restarted my pc.
Still not working. Do i have have to restart my router and streamer too?

Sorry to say.
I restarted everything still not working!


This indicates this could be network config related, however may I propose get the issue raised with our helpdesk and we’ll aim to get you up and running again.

Best regards

Steve Harris
Software Director

Thanks Steve.

How do i contact the helpdesk?


I have used the same set up, router and switch, the last 3 years.
This suddenly occured after i upgraded my pc to the lastest W10 (1903).
Thanks again.

Hi Fredrik,




It’s worth adding that the Uniti support line knows about current production Uniti, but not legacy Uniti, so for Unitiserve you need to contact the general support number.



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.