DSD, MuSo Qb and Bubble UPnP

Strange one…

Been using Bubble UPnP with Asset backend playing DSD files with zero issues to my Matrix Element streamer. Everything Bubble throws at the Element I it plays without a hiccup.

Now to the new MuSo QB. First off NAIM app plays DSD from Asset without an issue. However Bubble comes up with MIME Error (unsupported file type) with the same files. This is from different android devices… same error. Select Matrix as the renderer and it works fine. Tried with Bubble Server in the mix or not, same error.

Anyone else tried this test?

Thanks

Steve

I don’t think the Muso 1 plays DSD but I haven’t checked yet…

Doesn’t look like it does. :frowning:
https://www.naimaudio.com/product/mu-so-1st-generation

It does, Vr 2, because DSD DOES play from the NAIM app.

I’ve sent the log files to Bubble… will report back :slight_smile:

OK, my mistake :face_with_hand_over_mouth:

When I used Bubble I always used to use the Naim app play DSD. I wonder if the ffmpeg transcoding is tripping up with .DSD files?

Bubble plays DSD files without any issues to my Matrix streamer… so I’m thinking it’s a MuSo problem.

Have you set to transcode everything or just what the endpoint says it cant play natively?

No transcoding at all. Asset is the backend server and that is set to play all files ‘as is’. Transcoding is off on Bubble. As I say… change the end renderer to the Matrix Element streamer and it play perfectly okay.

I have transcoding enabled for everything and Bubble transcodes DSD64 to 192khz and plays fine on my ND5XS.

Yes this is an option but, since it works with the NAIM app, IMO it should work with Bubble so we’ll see what Bubble have to say.

Could I ask why you would be using Bubble on a Muso 2. I only used Bubble because I have a 1st gen streamer.

More used to it and it’s front end is probably the best I’ve seen on any UPnP control app. It’s very configurable so you can turn off a lot of the screen clutter and it’s very good for landscape mode which a lot of the control apps (NAIM and dCS) seem to ignore. In fact I remember having a ‘conversation’ with dCS about this and they said most of their users use an iphone in portrait so they don’t put much work into people using tablets in landscape.

Oh and it makes it really easy to switch between renderers without having to changes app.

Bubble have come back… they want some more logs…

I have a ND5 XS2 and use bubble because it lets me use Linn Kazoo on the laptop to control the streamer. I like the interface on the bubble app better than the Naim app and as @solwisesteve says it makes switching renderers from the same app simple. It also lets me serve up files from my QNAP NAS to the Sonos speakers in the house as well when Sonos doesn’t have native support for that.

1 Like

Although I was always pleased with the operation of Bubble I never found it a pleasing interface. It also has a confusing array of configuration options - less would be more here!
I maintain it as a backup at the moment or for checking things.

and, for me, the configurability is one of the good things. It takes maybe an hour working out what all the options do but then it’s a dream to use. IMO :slight_smile:

I agree, I’d rather have too many configuration options than too few. So good an app it is the only Android app I’ve ever paid the full price for :slight_smile:

1 Like

Well I got an interesting reply from Bubble after they got the logs…

I do not think the Naim app use UPnP for control.
Not sure why the MuSo does not like the dsd mime-type BubbleUPnP is using while it claim to support it. It’s not excluded the problem is coming from Asset (it also returns a mime-type to the MuSo when it makes the http stream request to it), even if it works with the Naim app.

The next test is to exclude the Asset and deliver a file direct from Bubble. So I need to download a file to Bubble and deliver direct to the MuSo.

Wow now that’s strange 'cause it DOES work if Bubble sends the file from a local copy. However what I don’t know is whether Bubble is doing any transcoding before it’s sent to the MuSo. I’ve sent Bubble the logs and should have an answer at the weekend.

Initial evidence though is it’s an Asset problem… though Asset can be the issue and it still works with the NAIM app beats me!

Update from Bubble…

BubbleUPnP uses mime-type “audio/x-dsd” when serving the http request initiated by the MuSo
for streaming. Since the track plays, it seems to point at a problem on the Asset UPnP side where
it may be using a mime-type the MuSo does not expects (such as audio/dsd).
I suggest to submit this issue on the Asset UPnP forum, with these details.
Maybe Asset has even a way to override mime-types.

The guess is that the mime-type presented by Asset for a DSD file isn’t what the MuSo is looking for or supports. I must admit I’m not 100% sure why it works with the NAIM app and Asset but not Bubble and Asset but I think it’s because the mime-type label that Asset presents is rejected - even though it DOES work with the NAIM app, presumably the NAIM app renames the mime-type.

Update on this… Bubble suggests that the MuSo isn’t using UPnP for file playing…