Firmware 4.8 update - NDX no longer seen on network

I’ve been the proud owner of an NDX for many years, the streamer has worked flawlessly. The NDX is connected to the network via a Netgear Smart Switch which allows me to stream music stored on my NAS drive. I use MinimServer on the NAS to access my music.

I recently upgraded the Firmware to 4.8 and all of a sudden, I can’t see the NDX on my network; the settings show a good connection with its IP address. The smart switch confirms the cable is OK. The Naim app can’t find it, it’s not listed on my connected devices on my Unifi Dream Router nor my PC. I decided to download the new app “Focal & Naim” but can’t set this up as my remote doesn’t have a home button! This is becoming frustrating very quickly.

Everything works, then nothing works! If anyone has an idea of what’s going on and can recommend a potential fix, I would be eternally grateful.

Have you rebooted the NDX and your control pad?

Yep, try rebooting your network and all devices.

Also try rebooting your router at the same time. Turn the router back on first, then the NDX, then the iPhone/iPad.

You don’t need to set up the new Focal/Naim app for the NDX. You go to the Naim universe or whatever nonsense it is they call it and then tap the link which says something like “go to my already set up rooms”.

Setting up the app simply isn’t relevant to any of the old green screen streamers, just to musos and the new platform streamers like Atom, NDX2 and so on.

1 Like

Thank you David, I’ll give it a go.

I did a factory reset on my NDS to get it work proper after 4.8 installation. Which of course always is best to do :wink:



I have a nac 272 and am facing the same prolem. When the nac loses network, I just need to switch between inputs on the device. Back to UPNP the network is intialized. Then the device is available a few moments later

Can I write this to support, are they interested in something like this?

I believe the title headline is misleading.
My NDX has been on 4.8 since it’s first release in 2021 plus before that with beta testing. Its not had a problem in all that time, that is until iOS16 coupled to the recent Naim apps were released. I had a few instances that seemed like a UPnP discovery problem when loading a new rev app (beta or public release) & each time it was quickly solved, & it stayed solved, by fiddling around with iPad or NDX front panel buttons.

I have a 272 and my app started dropping the room as well after the 4.8 update. Not a problem prior so I’m left with the 4.8 update being the culprit. Same situation, you have to navigate the inputs to get it to re-initialize. The whole process takes 2-3 minutes. Rather annoying.

I dont use the multiroom input, on the contrary i’ve disabled every other input. I’ve started a tidal trial about 2 weeks ago, the tidal input does not suffer from this issues.

Has anyone else noticed that webradio streams stop after exactly 5 hours?

Will naim ever solv this issues since the nsc has been introduced?

I haven’t noticed this, but then I never listen to webradio streams for five hours. But to me that sounds as if your router is not renewing a lease after five hours. You can probably adjust the lease time in the router settings.

This is Auto Disconnect, its a Naim selectable feature provided so that internet provider
data usage limits are not inadvertently exceeded.
‘How to’ will be different on whatever streamer you have, but on my NDX it’s set on the front panel display using the remote handset.
Tools …. navigate settings to ‘Input’ open iRadio and go to Auto Disconnect & there is a long list of hours to choose. I have mine on 4hrs.
As always, it’s (or should be) in the manual

1 Like

It is definitely not my router, when my router disconnects I am notified. Autodisconnect is set to Never.

I noticed this once on Sundays when I turned on the radion quite early, then of course I had to verify it a few times. It does not really bother me, I just noticed it

Exactly, it’s a Naim streamer function, see my post above

I know, see my post above

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.