Gapless Playback of Albums from Synology Stored music to Naim App

I was wondering is this possible? I get gaps between tracks on my bangin choons and wonder whether the issue is at the symbology or naim end? Any helps greatly appreciated x


You need to be a little more specific.
Is this a problem with albums that are supposed to be playing gapless but are not.
Or is it albums or playlists that you have that you want to reduce the gap between tracks.
What Synology media server software are you running
What file (codec) are the albums? (FLAC WAV or ???)
Are these taken from CD rips or downloads

Are you using the synology media server as UPnP server? Do you have enabled transcoding to wav? In this scenario the media server is buggy and is not playing gaplessly if e.g. playing flac.

Either turn off transcoding or use a better upnp server like minimserver or asset.

Another possibility: if you are not using the naim app but another control app this often results in gaps. You need an old naim streamer (not one of the new unitis) and a controller that is capable of and enabled for gapless playback.

Apologies gents for being unclear. I am not very IT savvy to be honest.

The files are .AIFF CD rips that should be gapless. I ripped to AIFF to get the album art embedded and maximum quality which would show/play across all my formats.

The files should play gapless. Indeed they do so when playing the same files through plex server

I am not sure if through UPNP or not. I looked for servers on my naim app and found my DS918. I couldnt say whether its found UPNP or not, it just says SynologyDS918. The file structure is there on the Naim app, finding my music filed by album but gapless is not happening for me. Thanks for some pointers, i’ll have a play around. :slight_smile:

OK, not answered what I wanted to know but I think I get the picture.
You are playing from your Synology & it appears that you are using the Synology DLNA/UPnP software called Media Server. Have a look in the Synology GUI (the PC/Mac/laptop control screen) & look into the Packages Center & see what is listed in the Installed section, it will always show Search & File Station, I’m expecting “Media Server” to be install as well. Tell me all that is installed.
TBH Media Server is not the best of UPnP server software & when I used it I also had trouble playing gapless. In my case it was activating the transcode feature - this converts whatever codec you are playing to raw PCM. I eventually converted all my collection to WAV & it played that perfectly without the need to transcode.
So the first thing is to check that the transcoding check boxes are off, & then try that.

If that doesn’t fix it, you should try installing the 3rd party software called Minimserver & the also needed Java. Its not so simple to install or configure as is Media Server, but it works so much better, including transcoding & gapless.

Keep us osted with how you get on.

This is most likely the problem. When I first hooked up to my Synology I was getting gaps between songs, most noticeable on live albums. It was driving me nuts! Then I turned off transcoding and it went to gapless. Happy man again. :grinning:

Turned off transcoding as advised which removed the gaps so many thanks guys for helping me fix it. :pray:t3:

1 Like

Seems that searching by album instead of by folder yields the best result for me to get gapless playback…

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.