HDMI ARC not working perfectly after recent update (


I have a Nova running the latest firmware. I mainly use for Spotify Connect and TV via HDMI ARC.

I had some major issues a while ago about the sound not working at all from the Samsung TV. But it was fixed a few months ago thanks a fix from Naim.

Now, after updating to the latest 3.6.0 firmware, I’m experiencing some issues with HDMI ARC again. The sound itself works fine. However, when running Spotify, and then toggle to HDMI, it sometimes get stuck at Spotify (showing the huge Spotify logo on the Nova display). And sometimes the Nova toggles to HDMI, but says “No input sound”. Then back to the huge Spotify logo on the display. I have tried to toogle to HDMI via Naim remote control, iOS app and the on device-buttons. Same behaviour for all three. After rebooting both Naim and TV I have no problem getting the HDMI source working. And going from HDMI to Spotify always works.

So last night, I got so eager to solve this, I did a factory reset on both the Nova and the TV to force a new handshake between the devices. Also unplugged both devices for 20 mins. Worked perfectly last night. Earlier today, back to the same problem again.

My TV is running the latest firmware too: T-MSMDEUC-1374.0, B4970101/070204, BT-S.
Digital audio output: PCM

Any ideas why this is happening? Something else I should try before reaching out to Naim support?

Had similar experience on the atom. To resolve I have set the arc setting on the Samsung TV from auto to off. Now works perfectly, Uniti switches on and off when TV is turned on/off etc

Thanks for you quick reply @Zhenya. Do you mind sharing how you did that?

This is how my settings looks like right now:

When I googled it, I found this one, but system menu doesn’t look like my own TV’s settings (different firmware/model I assume): What eARC is and how to set on Samsung Smart TV | Samsung Levant

Good idea to start a thread on this. I have an issue where my Atom will auto switch to HDMI on LG TV but i can no longer control the volume with my TV remote… really frustrating. I hope i am not stuck with this issue for months until the next update. I have emailed customer support with the problem but have not had a response yet. The only thing I haven’t tried is to factory reset both units. Ill give that a go when i get chance.

Mark, what’s your support ticket number?

Your Ticket Number is 106951

It’s ok mate I can wait, I understand they are busy.

1 Like

On my TV (FW 1420) the settings look like this

Thanks Mark, I’ll pass it along to support.

Thanks for showing screenshots @Zhenya. Seems like we have different TV’s and firmwares running.

I tried a second factory reset today. Now I’m experiencing something completely new; a weird noice when running HDMI. I tried the Youtube app via an Apple TV that is connected to the TV. Worked perfectly. Started Netflix, and this sound started (see link below). Doesn’t sound good at all. I tried a few more apps - Plex, via Apple TV, and still the same weird noice coming out from the speakers.

Might it be the case that your Uniti is not connected to the Arc HDMI port on TV and this is the reason the settings do not allow you to change the Arc connection type? The rest of the menu points seem similar to me

It is connected to the third HDMI port on the TV that says “(ARC)” and it was working before upgrading the firmware with the same port, so I just assume it is the right one :smiley:

1 Like

Factory reset on what? If the tv perhaps you flipped audio to 5.1 over stereo speakers?

1 Like

@garyi You’re right - that is exactly what happened. Switched back to Stereo now and all apps works again.

So second issue now solved. Main issue still remains.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.