HDX can’t see or find Synology NAS

I own 2 Naim HDX. One in both Copenhagen and Brasil. I have experienced some problems with the connection to the NAS in Copenhagen. The HDX can’t find or see the NAS. The NAS works. My Steinway processor and IPhone finds it and plays from it. Only the HDX can’t.

@ChrisSU should answer

This is usually a discovery problem associated with the router/switch (or sometimes other network components if present), or with network addressing.

Have you tried plugging both into a separate switch and connecting that to the router?

Are all the devices on your network configures to use DHCP (rather than fixed IP addresses)?
If not please try using DHCP for all your devices (to prevent address conflicts), and then restart the router… when that’s fully restarted then restart all your other network devices.

Ok. I don’t know who CrisSU is.
Some years

1 Like

Thank you Xanthe. I actually have no idea. As far as I remember the problems started 3 years ago, shortly before my departure to Brasil. The HDX simply lost connection to the NAS. The NAS was set up by Phil Harris from NAIM. Phil offered to fix the problems online via the TeamViewer. TeamViewer at the time did not install on a MacBook. That has since been resolved. The HDX is connected to a switch which is connected to the router. My Steinway system is also connected to the switch. The NAS is connected to the router.
I’m further than up to my neck in this problem. I have idea what DHCP is.

why not connect the Nas to the switch also?

I did and the brand new NAS shorted. I have a lot of bad experiences with Synology. I live in a brand new apartment. All installations should be checked. I’m not sure they’ve been.

What happens if I put the HDX back to factory settings or should I reinstall the latest update 1.7b?
I know the question sounds a bit stupid.

If you mean you did connect the NAS to the switch as suggested by French Rooster, then that does not make sense at all.
Its absolutely standard practice to connect NAS to Switch & Switch to HDX & a branch from Switch to Router.
If that connection did cause a short (damage) to the NAS, then you need to look into the network wiring itself urgently & have each ethernet section continuity tested.
And that testing might find the reason why your HDX can’t see or find the NAS

sometimes i lost connection with my past unitserve. I used to restart the router, wait, then restart the serve, wait, and finally the streamer.
It worked for me.

I wouldn’t reinstall existing firmware in your HDX without checking with Naim first.

Incidentally the latest firmware is 1.7c but you have to ask Naim support for that and they may be reluctant to send it out when your HDX doesn’t seem to be working normally. You can’t download it.

Best

David