HDX Network Sharing

Just set up an HDX in my system and can’t get it to access music on network devices. I’ve set up the Desktop Client, found the PC I want to access and enabled sharing of the relevant folder, but the status seems to default to offline in the DC even when it should be online. Really scratching my head here. Any ideas?

The PC needs to be running UPnP server software - have you set that up?
Without it, the HDX won’t “see” the music you’re trying to find on the PC.

Hum, thats not correct, The PC just needs to have SAMBA sharing. However where as the HDX is built on technology from way back when, windows et all has moved on. SMB1, has been switched off by default, I believe that really the HDX needs this to function correctly, there are methods to turn SMB1 back on.

The reason, as I understand it SMB1 was turned off, is because it’s unsafe in todays world.

This is inherently the problem with HIFI computer audio IMO, far more milage in a damned good USB DAC.

I stand corrected.
I use a NAS and it runs the UPnP server software Asset, so I thought a PC needed the same.

Stupid me for imagining that it would be easy to play music from other devices. I didn’t know I’d need to be an IT whizz! So I don’t necessarily need Upnp server software if I enable SMB? Looks complicated, or at least a faff.

You can always rip your CD’s the HDX itself, or attach a USB directly to the HDX.
But yes, streaming / playing digital music can be a faff !!

I find the ‘browser interface’ the best way to enable network shares on a Naim server. Put the IP address into a browser, and follow the instructions in the manual.

Its odd Ken, because you can at least see the PC, this is often not the case but lets make sure you are doing it correctly?

Find the music folder on your pc, right click it and sharing, (Or similar)

Your aim is to share that folder to anyone, once you have done that click apply. Give it ten minutes then run a scan from the HDX. You might get lucky and the music folder will be picked up. If you can see its picked up but doing nothing you may need to enter a user name and password which would be the same as for logging on your pc.

If its still not working, then goto google and type in ‘enable SMB1 windows 10’

Its like the first thing that comes up.

Be aware that enabling this feature carries risks, probably limited within a home environment to be fair, but they did turn it off for a reason!

Finally make sure you are on the latest update, 1.7b I think it is on the HDX.

The latest update for HDX is actually 1.7c and it’s essential because it stops the HDX hanging while looking for the defunct AMG metadata service during a CD rip. You have to contact Naim support for it and they will supply a disc with the update on. They haven’t made this update available through their website. Incidentally 1.7c has to be installed on top of 1.7b and that has to be installed on top of 1.7a so check what firmware version you have before contacting Naim. The DTC will tell you.

Regarding SMB 1, HDX uses that because Windows XP Embedded never implemented SMB2 or SMB3. Its easy enough to turn on again in your PC. I’m not sure whether that could be why the DTC doesn’t manage to turn on sharing of a NAS folder, but I would give it a try at least.



SMB1 is enabled, and the music folder is shared, so neither of those should be the problem. The HDX is running 1.7b, so I’ll get on to Naim for the update. I wonder if it’s a password problem - should I use the PC name or my user name?

I’ve tried on a Mac too and it’s a similar story - n-serve is installed and i can see the HDX on the network from the Mac, but not the other way around I don’t seem to be able to share the music folder on the MAC either but that’s probably a different problem.

Tried entering the IP address in a browser window but all I get is a message that Flash is blocked and an invitation to update.

I don’t think you should need a password at all. I suggest you register it as a problem you need help with by calling or emailing Naim Support.



You probably just need to enable Flash on Safari. You then get an interface that is similar to the HDX front panel display, but full sized, and with some added features.

I vaguely recall something about having the HDX in the correct “Workgroup” (I’m not 100% sure this is the correct term as I’m not terribly tech savvy) so could this be the issue here?

1 Like

@Stevesky clarified this workgroups issue recently in a beta group posting. This is the relevant bit of what he said:

“Re: Workgroup

The Core vs Unitiserve work differently on how they handle workgroups. Its a linux samba vs windows xpe thing.

On Unitiserve it will find any network share independent on workgroup name. This was defined by how Windows XPE worked in the depths.

On Core the workgroup name will limit what it can find. So by default it’s in the workgroup ‘naim’. If you have a NAS then it must also be in the workgroup ‘naim’.”

Of course HDX is like Unitiserve rather than Core, so I don’t think the workgroup settings are relevant to the OP’s problem.



Looks like my tinkering about with various settings in an attempt to get the HDX to read from network shares has caused a conflict with Print Spooler, meaning I’m now unable to print and I can’t see how to resolve it. What a mess!

Indeed, time to move the HDX on!

I think he may have only just acquired it!



I don’t know where you have been looking to make any changes, but as per my previous post, have you enabled the folder you want as a Network Share? You can, as I said, do this on any browser, but on the HDX, I’m pretty sure it can also be done from the front panel display. Have you read the manual, which explains exactly how to do this?

I seem to recall that I once had an issue where I added a Scannable Network Share in the Naim Desktop Client under Tools->Music Repositories using the correct username/password and it was added in Offline mode.

After clicking on the newly added share and clicking the ‘Set Password’ button on the right hand side to re-enter the same correct username and password the share then came online.

Worth a try?

Yes, I’ve done that. I’ve tried most if not all of the advice above as well as everything in Naim’s advice here https://www.naimaudio.com/sites/default/files/products/downloads/files/tech_support_doc-network_scanning_hdx.pdf.

The only result is that print spooler won’t work and nothing I’ve tried as a fix will alter that. There’s clearly a conflict caused by a setting I’ve changed, but I have no idea what.