HDX or Router Issue

Hi All

haven’t been on here for a while, such a long time I had been removed.

Reason for being back is HDX issues, Error 58?

For some reason or other my HDX has stopped seeing my share and external store. no changes in anything, all good. only thing is i powered down my HDX for a few weeks

I am using Apple Airport Extremes as my home network, and have just finished resetting them to factory and reconfiguring them

strange thing is the usual ip addresses of 192.168.0.### have changed to 10.0.1.###

it this a router issue or even my virgin cable modem?

confused and frustrated

Thanks for looking

If your HDX is showing a 10.xxx IP address it’s probably failed to get one from your DHCP server, which is presumably in either your router or the Airport.
The first thing I would try is to shut down your whole network. Then start the router. Once fully up, start each Airport Extreme, one at a time. Then the HDX, then the device you use to control it.
Hopefully after that the HDX will have been allocated a proper IP address. If not, you may need to dig a little deeper.

10.xxx from memory is the default for an Apple Airport.
You need to disable the DHCP on the Virgin router or on the Apple Airport.
I suspect there’s a clash.
If you were seeing a 192.168xxx IP address before, it looks as though your Virgin router was dealing with routing duties.

the crazy thing is that even with as the dhcp assigned address for the HDX, all is fine, it can find internet radio and i can see the hdx over the network. i can also use my phone app to control the HDX

my Nas drive works and all my alexa and tv/netflix work, all with this crazy ip addresses.

only thing that will not work is the HDX seeing external shares and stores

not sure what is at fault, but something isn’t right.

will be returning DNS to my virgin supplied router (after i get it out of modem mode)

thanks for info

If you’re using a different DHCP server now, it more than likely has caused IP address issues.
If you look at the Network Shares in the HDX System menu, are they still listed? You may just need to re-enable them.

If your Virgin router was previously acting as DHCP server, revert to that state first.

We use a Hub 3 in modem mode with an Extreme doing everything else and it’s worked brilliantly for about five years. No way would I let the manky Hub loose on my network.

I’d check that you have the second Extreme set as an extender, otherwise if they are both giving out addresses it will end in tears.

I’d suggest looking in the Airport Utility app to ensure everything is correct.


The plot thickens

With the virgin router in modem mode and a full reset of my network. Back to factory. I get weird up addresses( both airports act the same, I have changed so each airport is the main and the other is the extender, don’t know proper terminology but understand more than the basics). All network works apart from hdx will not see shares.

With the virgin router in router mode and the airport network in bridge mode all works fine. Shares work and I have normal options addresses ( don’t like this config as virgin always drops out and in this mode I lose internal network so can not print do heating lights or listen to music)

I can not replicate how I started this issue, basically for about 6 years I have not changed the network, share and stores were fine. Only change was I powered down the hdx for a good few weeks and powered back up and I was in this mess

I don’t know if it’s the virgin router playing up. Or if it’s my airports?

A new mesh system may be in order but struggle to find a reasonable priced one with 3 or more Ethernet sockets on

Alternatively may just be the virgin router

Any suggestions appreciated

Thanks all

Could you, at some time in the past, set a fixed IP address for the HDX or shares?
Maybe it’s looking for shares on IP addresses no longer assigned to the shares.
If you haven’t done so, do a network scan to view all devices IP addresses.

Nothing wrong with this… they are both valid private address (RFC 1918) address ranges. Your DHCP server on your router or elsewhere will be setting this address range scope… though best practice on small home networks is usually to use 192.168.x.x, but you don’t need to, Apple for a while used default 10.X.X.X for some strange reason… it’s valid but usually not really recommended for small network address ranges/subnets.

The main thing is to ensure everything on your home network is set to use dhcp otherwise you will need to manually set the ipv4 addressing info… not really recommended. Also check you have only one active dhcp server on your home network. Do double check the subnet mask, as these can in many default settings be quite different between different RFC1918 address ranges.

In short everything needs to work to the same address range (network address) and subnet mask so they can communicate with each other. This is the most important part, as opposed to be physically connected together via an Ethernet cable.

As far as the shares, how are they defined? Are they defined with a name, in which case your new router needs to understand that… can you see the name in the client list on the router when the NAS connects using dhcp?

If not you may need to manually assign numeric addressing, not ideal, but if forced to because of limited router dhcp/dns capability, then you need to manually remap the shares to the new IP address given by the new dhcp scope, and then reserve the IP address of your NAS in your router dhcp so it always assigns the same ip address.

The preference is to use named devices and dhcp that stores and maps the names against the IP address in its DNS… this is automatic for many consumer routers… and if working effectively plug and play.

Here is an example of my share using DNS name ‘ nas-35-37-. ‘ instead of a numeric address so it’s relative.

I wonder if the OPs NAS has updated recently and he is running into the SMB1 issue.

This is the crazy thing. My network was working fine. Hdx seeing shares on nas. Hdx and my 2 nas drives have there own ip address assigned through reservation in the airport. Based on MAC address, Everything was perfect. No NAT or DNS conflicts

The Naim just stopped seeing the shares after it had been switched off for a while

I have tried 2 separate airports and the hdx will not see shares

Now I have tried a 3 AirPort Extreme. Still no joy

The only way I can get this working is for the virgin box to do the routing and the airports to do the wireless. Have 4 airports in total all been working for years trouble free

Have come to the conclusion that the virgin router in modem mode is doing something to rock the boat. Don’t see the point of hard resetting the forth airport

Just a update for you all

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.