Help: ND5XS not appearing in Spotify Connect, nor Tidal - can’t connect anymore

Hello all, this is my first post and have been reading a lot of related ones, but still no resolution found.

Since quite some years now I am the happy owner of a Naim ND5XS with a Primare i30 and Audio Physic Tempo 35 speakers. Traded in my CD-player for the Naim at the time the 2 came out.

We used iPhones, iPad and a Macbook Pro succesfully connected to the ND5XS with the apps, but recently only my wife’s iPhone X shows the ND5XS in the Spotify Connect. The Naim does not appear anymore on my iPhone 12 mini, despite having the same iOS, nor my Macbook.

I tried Tidal again by resubscribing, same issue – the Naim doesn’t appear in the device list. I tried the Naim app, which worked fine and was streaming iRadio and my iPhone was connected to the streamer able to toggle input sources. On a side note, recently I updated the Naim app, which apparently lost connection with my ND5XS and re-configuring doesn’t work as it cannot find my streamer anymore.

Since I checked all firmware, app versions, rebooted everything ultiple times, etc. etc. Changed from 5 and 2.4 GHz to 2.4 and to 5, no effect.

The streamer is connected to the router by ethernet cable. Probably the troubles appeared (but not sure) after I replaced a wifi booster station with a Ziggo setup (DECO) which made me switch off the wifi on the router itself (so the DECO’s could take over I guess). The setup was done with the DECO app on my iPhone.

So the strange thing is that my wife’s iPhone is working perfect, meaning the Naim gets visible in the Connect function of Spotify.

I don’t have a clue left where to look. Does anyone have any suggestions? Thanks for any effort!

1 Like

It sounds similar to a bad router link or IP Address
I would try a complete system power cycle.
Turn it all off including the router, leave it off for at least 5 mins to be sure the ISP has logged it off.
Restart the router, let it finish its restart process.
Next start the network extender
Then ND5 and last the control point (iPhone)


Just to add some more weight to your post, I’m also having issues with Spotify - something that has only recently happened. I’ve made no hardware (or Firmware) changes to my system (audio or networking) and other units connected to the same ethernet switch as my Superuniti can access the outside world - i.e. the TV can stream via iPlayer). Spotify cannot see my Superuniti as a device.

Hi all,
While listening to my ND5XS at about midnight on 01/11/2023 the phone app stopped discovering the streamer and stopped streaming tidal mid song. Now the apps not finding the streamer and I haven’t touched any of the equipment in the chain.

Make sure your existing router and the deco WiFi aren’t fighting each other over dhcp; mesh systems sometimes have dhcp enabled by default, but you want the router doing that, and disable it in the deco. Otherwise you’ll have 2 networks and devices on 1 that can’t see the other.

1 Like

This can’t be done on the iPhone - do you have two wifi networks, one for each frequency, with different names?

The DECO-app has this functionality.

Thanks! This I can look into, but somewhere along the installation process I had to disable wifi coming from the router so that should be switched off.

Hmmm may be a very similar cause…

Thanks, I will try that for sure (although I think I did that once).

Hi, it’s not router WiFi, it’s router dhcp versus deco dhcp; make sure the deco dhcp is disabled else you will have 2 home networks and devices on one won’t see devices on the other. It’s not always the case, but some mesh WiFi systems have their own dhcp server switched on by default.

1 Like

As the router’s wifi is switched off (as instructed), shouldn’t the router’s DHCP then be switched off as well? It’s a Ziggo Connectbox Giga then hardwired to the DECO’s.

Not necessarily. Log into it and see if it’s still running. If so, it will show a list of client devices to which it has allocated IP addresses. Either turn it off, or or leave it on and turn it off on the Deco.

1 Like

My DECO-app says it is in Wifi-router mode (hence not AP) and then NAT- and DHCP-servers “are automatically switched off”. Before that, I turned off DHCP on the router (didn’t reboot btw) but found out that my hardwired streamer lost connection to the router. Just turned it on again.

If your Deco has switched off DHCP and you turn off DHCP in the router as well, you don’t have IP address allocation anymore, hence no network…

Yess, it dawned upon me after half a day or so :smiley:

Did all of that, no change: my wife’s iPhone is the only one able to select and play via the streamer in Spotify.

If you go to the WiFi setting in the settings of your iPhone, and you click on the (i) symbol at the right hand side of the screen, next to the name of your WiFi connection, you will go to a detail screen.

Is the option ‘private WiFi address’ selected? If you unselect it, does it work? I noticed in the past this obfuscation method sometimes causes problems at home networks.

Hi @jmtennapel that function is designed for public wifi connections and should not affect being home

I know, but it has been fighting with home networks in some instances.

1 Like