[Help needed] Wifi Problem on Uniti Atom HE

Hello fellow forum members, and the Naim support team.

I just bought a Naim Uniti Atom Headphone Edition, to pair with a Focal Stellia and an the Sennheiser HD800s. I bought it second-hand, from a reliable seller, an authority on high-end audio equipment here in Brazil.

However, I received the product yesterday, and although the unit is in perfect aesthetic condition, and in the original packaging with all the documentation, I noticed two potentially problematic things.

  1. The plug/slot for connecting the power cable seems loose and wobbly. Is this normal? Does the slot really supposed to move even after inserting the cable?

  2. The other (and bigger) problem is that the device simply does not find any Wi-Fi networks. Trying to locate networks manually, it doesn’t find any, and the Naim app also doesn’t locate/recognize the device in the initial configuration via WiFi. I’ve already tried doing the factory reset twice through the configuration menu and the problem persists. (Is there another way to factory reset?) For now, it is only possible to connect to the internet via wired ethernet cable. In this scenario, the Atom works perfectly, but it leaves me stuck using the device close to the router, which is not pleasant and ideal.

Could anyone suggest what to do? I’m in Brazil, which makes the in-person technical assistance process difficult (although it’s not impossible, since we have an official Naim representative in the country, but in another city). Could it be a hardware problem? Or would it be possible to try to downgrade the firmware or something? Ps: It is already in the most current version.

Ps2: There is still time to return the product. Should I?

Thanks!

  1. Yes, that’s how it’s meant to be.

  2. Sounds like something related to WiFi network security - frequently configured to block unrecognised new connection requests to prevent the WiFi network from being compromised, setting in WiFi router or software like Fing?

ATB, J

1 Like

Is there any way to manually downgrade the firmware of the unit, via USB?

Maybe it’s a software issue that can be solved downgrading, and upgrading again.

Tks.

Not that I have seen documented anywhere. Also I think it auto prompts you that a new version is available and offers a yes/later option to install but no option to decline indefinitely.

This occurred on both my HE and subsequent 222, although in the latter case I declined until the initial setup had completed.

As I have (boringly) said elsewhere, do not install anything until you have read the release notes, but, hey, what do I know?

ATB, J

1 Like