Help please - HDX says Synology NAS is offline

Wondering if some kind soul can help me. I have an HDX with a Synology DS218j being used as a network share NAS. This was all fine until yesterday when I had to reset the network router (ASUS RT-N66U) in an attempt to fix wi-fi issues. Since then the HDX is not pulling the music in from the NAS and if I look at the Scannable Network Shares menu in Tools on Network Client it says that the NAS is offline. My PC can see the Synology NAS fine and sees all the music files ok. Similarly the PC can see the HDX and all of the music files that are spread across the music and downloads folders.

I had a similar problem after a power cut a year or so ago but managed to set settings etc that got it working again, but am failing to do so this time. I have also tried the aged old ‘turn it all off and on again’ routines but am having no success, hence the appeal here for help before I go to the Naim support team - the support pages on the web site say to try the good and helpful people on the forum…

Many thanks in advance for any advice anyone can give. Please note though that I am a long way from any form of system/network expert who understands how all this stuff works!

Thanks, David

@ChrisSU may help. Or @davidhendon

Thank you to @frenchrooster for his confidence, but @ChrisSU is more knowledgeable than me on HDX/Unitiserve. My immediate reaction is to note that the HDX thinks the NAS is offline which I think means it’s not accepting connections from the HDX, either because it isn’t getting the requests or because it doesn’t know who the HDX is.

I wonder whether resetting the router has changed something about the IP address that the NAS or the HDX has been assigned by DHCP in the router. Did/do you have any fixed IP addresses allocated?

Also I wonder whether you could try adding a new share (ie your NAS as it is currently) to the HDX. Or maybe allocating the HDX as it now is trusted status in your NAS setup. @Mike-B will know more about that than me and whether it’s a thing. Anyway that should give you some things to work on until they stop by here.

Good luck.



I recently had a similar issue with my HDX. The solution turned out to be rather mundane; for whatever reason required a reset of the password for the NAS drive (no change in the password, just re-entering it on the the HDX and all worked fine).
Previously had an issue with Austor NAS drives after a firmware upgrade that also required a reset of the passwords in addition to resetting the shared access to the NAS drives. Your NAS drive hasn’t automatically upgraded it’s firmware? Issue I had was that the DHCP address was being constantly reset by the NAS firmware every time my main computer was being rebooted such that the NAS DHCP connection was continuously being lost. Fortunately for me another firmware update a few days later corrected the issue and stability to the connections to all systems accessing the NAS was restored.

Could the default router configuration block upnp. I think there was some configurations with that kind of issue way back? Otherwise can you create a new share to the music on the nas?

I think all the previous discussions about routers blocking upnp were rather misinformed because it’s upnp from outside the LAN that is sometimes blocked for security reasons, not upnp on the LAN.

Also the HDX seeing a share on a NAS is nothing to do with upnp anyway!



Yes access restrictions to the shares would make more sense, but if the only change is a reset of the router it is hard to come up with the obvious answer not knowing the specific router and network configuration, but asuming hdx and nas is wired into the router and devices are connected wirelessly using the router for that also.

… errr likewise, thank you for the confidence, but truth be told I’m not at all familiar with HDX.
That said I understood networking with HDX & adding a NAS share to be similar to UnitiServe, so a US man might be able to help.

Many thanks to all who have taken the time to contribute some ideas here. I have finally had time to take a proper look and try some of the suggestions…

I thought that @davidhendon’s thought on fixed IP addresses might have something in it as I am sure that last night when I was reviewing settings on the router it was saying that the HDX was static vs all other connections saying DHCP. When I looked again today though it is showing the HDX and all devices connected to the router as being DHCP so possibly a red herring.

A couple of you suggested trying connecting to the NAS as a new share, ignoring the previous connection, given that the NAS is showing as being on the network this seems a good idea. I have taken a look at this using the ‘Add new…’ button in the Scannable Network Shares and also using the touch screen manage shares. Being something of a computer numpty I am then struggling to put in the correct details when it asks me for the Share Path so am not succeeding on this at present.

I have also tried Geofiz’s suggestion on password, re-entering it on the HDX, and then also resetting on both the NAS and the HDX, followed by a reboot of both devices. Again no luck.

Thinking and reading through again my logic would assume that it is possibly some setting somewhere on the router as that is the device which was reset. I have already spent some time looking through these to see if there is anything obvious that stands out but most of the settings and comments etc are well beyond my understanding but I will spend some more time looking and experimenting. It is all pretty frustrating as it is probably just some little setting that needs tweaking somewhere!

Thanks again to those who have contributed, very much appreciated.

I suspect some kind of ip conflict. I’d power down everything then unplug everything. Wait 10 minutes then starting from the front which is the modem>router>nas …and so on. In case you don’t know DHCP is an IP address that’s automatically assigned by the router. A static ip is one a person would select that’s fixed and doesn’t change.

I am pleased to be able to say that this morning I now have it all working again, although I am not fully sure exactly what has sorted it. After my post late last night I followed up Geofiz’s question about possible NAS automatic firmware upgrade; the answer was that it hadn’t done so, but it did show that there was a firmware update that I could do. I therefore did this and tried rebooting etc but still with no joy. I then made a change on the DHCP router address range and after that and turning it all off an on again the HDX magically showed the NAS as online. It then wouldn’t play the music files off the NAS but overnight I let it rescan and update and this morning all seems to be working perfectly.
As you can imagine I am very pleased and relieved. Thanks again to all the input and suggestions I have had on this, not only have I got all my music back but I have also learned a bit about how the system works and DHCP which I am sure will be useful in the future.
Thanks and best wishes to all.


Great that you are backup and able to listen to music via your HDX again!

1 Like

Hi, one thing that makes debugging easier is to remove all passwords on the nas until hdx is back in contact with the necessary shares.

1 Like

And something that makes future debugging easier (and less likely to be needed) is to leave everything on DHCP and always resist the temptation to fiddle with setting fixed IPs. The latter is liking picking at a scab - it may feel nice to start with, but never ends well.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.