Help with nDac firmware update please

I’ve this nDac which had an older firmware version (done the Apple iPhone thing)

I have:

  • found the webpage with the link to the 4.11.8 version
  • downloaded the file
  • copied the files to a USB stick, removing the empty folder and the instruction .pdf
  • turned the Dac off, disconnected the mains cord and let it rest for at least 15 minutes.
  • Turned it on again, waited for the lights to settle
  • inserted the USB stick.

All the five lights went on, but stayed on. After one hour, nothing had happened. Stuck.

So I:

  • turned the Dac off and disconnected the mains cord.
  • downloaded a fresh file directly to another, better USB stick.
  • removed the .pdf with instructions and the empty folder. The five files were ok.
  • turned the Dac on, but at this point:

The five lights were still on before the USB stick was inserted.

I inserted the stick. Nothing is happening. I did it at least fifteen minutes ago and it’s still five lights on and nothing happening.

What have I fu**ed up?

Thanks.

1 Like

It’s been a long time since i did this but the main point is to ensure the USB stick is compatible so ensure you can play a WAV file from it first. Ndac’s are very fussy about which USB sticks they work with

2 Likes

Thanks, but it’s a little late now to try a WAV file. The Dac is stuck with the five lights on and unable to do anything.
Anyway, the first USB stick I tried had been previously been loaded with a full album in WAV replayed successfully. And of course both are FAT-32 formatted.

Anyone with a prospective suggestion?

I remember there was a way to force an update plus some discussion on going via an intermediate firmware level before loading the very latest. From googling, I found this comment:-
Posted on: 05 December 2015 by CharlieP

Santi,

Try this:

please try a forced update procedure

by pressing the dock and 4 button simultaneously on power up. When doing this all buttons should blink 4-5 times just after power up. When the buttons have stopped blinking and are ON the unit is ready for updating i.e. this is when you insert the USB stick (v4.10.6) with the update files.

Charlie

And also this:-
Posted on: 06 December 2015 by Santi

Hi everybody, I 've great news my nDAC has been repaired!!

Most of the topics which resolved the issue had been posted by the members. I post the actions just in case someone would need it:

1. Old USB stick used with memory capacity of 512MB.
2. USB stick formatted in FAT 32.
3. USB stick loaded at the nDAC back.
4. First loaded to previous 4.10.6 update version.
5. Next loaded to the latest 4.11.8 version.

Thanks again to all repliers for their useful help. This is my second post but am still impressed about the expertise available.

Santi

3 Likes

Thanks very much. I’ll try it now. It can’t make things worse.
M

Please does anyone have an idea how to get the intermediate software 4.10.6? I googled everywhere with no success.
Thanks very much.

Quite possibly Max! However, without breaking the Forum rules here, I’m sure Google will allow you to find me! :wink: :joy:

KR

Peter

5 Likes

Thanks, I’ll do my best to. :smile:

Kind Regards

Max

2 Likes

Sorted! Thanks to a couple of good guys.
:hot_face:
DAC now 4.11.8

12 Likes

So… can you elaborate on what you did, for the benefit of others who might have the same issue now or in the future?

1 Like

Considering my one with unknown firmware is being installed tomorrow morning I’m definitely interested though I will have dealer expertise on hand it’s still nice to have possible solutions just in case.

1 Like

Glad it is sorted; seems like a standard affair with various USB drives kicking around…

As a techie I keep my old USB drives for firmware updates…

simply formatting modern USB drives as FAT32 doesn’t always cut it…

find an ‘ancient’ (sub 4gig, idelly 2Gb or 'less size) and format it fat32 (whole drive, no extra partitions, especially drive backup software etc (eg Sandisk ‘rescue’ software as an example))…

should be straightforward from there… (follow webpage instructions)

I understand this has been sorted; cheers to the above…

2 Likes

Of course.

First I checked the current version with the iPhone (the instructions for using the front buttons were a but complex at first, but then became clear, it’s enough to read patiently the .pdf). It was 3.x.6 (forgot the second value) so in fact old.
I downloaded the 4.11.8 version, instinctively (not specified in the .pdf) took the five files out of the folder and put them in a USB pen I had - new, cheap, 32G. I turned the DAC on the proper way, inserted the pen in the front socket. The five buttons lighted up and stay so for more than one hour…

In short: I thought I had fu**ed it up. Took the DAC to a friend who’s the informatics genius in an audio shop I know. The DAC was simply stuck waiting for a update but couldn’t see any pen. BTW, in one my moves it had gone back to 2.5.2 version, no idea how and why.
Then we found a pen the DAC liked. First we charged 4.10.6 - a few seconds - the 4.11.8, almost instant.
All ok.
(The USB pen that had first not worked had in fact been seen by the DAC earlier, when I replayed a whole album. But not with the software…)

Résume:

  • Keep a few USB pens at hand - old, verified and ‘small’ in size - not more than 1G, even less. I had tried with a 32MB one which didn’t work anyway, so it’s not the size but who knows what.
  • Follow the instructions carefully about how to turn on the DAC.
  • Insert the pen in either USB socket.
  • Cross your fingers.

Best
M

3 Likes

Exactly so.

Very glad you like the nDac, Max. I have been thinking of your nDac experience in terms of newspaper headlines and stories:

Arcore man in source first shocker! Exclusive!!

A resident at the Arcore Home for The Perpetually Perplexed was today shocked to find that the 'source first doctrine’ in his hi-fi system actually works. Self-confessed audiophile Dr Max Bertola, who used to work at the prestigious Milano Conservatoire is no stranger to rash and ill-considered decision-making, was heard to say, “blow me, fitting the nDac works”.

Dr Bertola, rumoured to be in his seventies but kept eternally youthful by his all too frequent associations with attractive young women, attributed the sauce first success to his Naim Audio forum mates. One un-named source in particular, a ‘close friend’ of the writer, is a pedantic Brit with a hygiene problem who lives on the south coast of England in a pokey one bed flat and has not got two friends to rub together. The source said, “It’s a miracle really. Max is a lovely bloke but for too long he has been under the influence of American culture. I’m thinking here of that august academic journal Stereophile. Pointing to his head, the source said that "Max should know by now that it’s up here for thinking” and then pointing to his feet, “down here for dancing.”

Asked by The Arcore Daily Times where the money went in later life, Dr Bertola invoked the spirit of the legendary Northern Ireland and Manchester United footballer George Best: “It went on birds, booze, and tired old discontinued Naim pieces in need of a service. The rest I just squandered."

[Continued on pages 4,5,6,7, 9, 11 and 13, and for more on this breaking news story, don’t forget The Arcore Daily Times in-depth exposés all next week, and the week after that, and the week after that etc. etc

Alright, that’s enough - Editor]

6 Likes

^^^^ Yes, I checked with Max first that it was okay to post this :slight_smile:

C.

2 Likes