How can I get my Uniti Core to power on?

My ultra reliable Uniti Core has failed me all of a sudden. I was all set to rip a new recording and it is “dead”. I have tried repeatedly to power it on. Failing that I depressed the power/standby button for 20 seconds, waiting for the unit to come to life and return to factory settings, but nothing. Is there anything else I can try?

I am guessing you have checked the power cord connection? Perhaps swap in a different PL and then my next logical check would be the fuse before looking at anything else.

I have double-checked and triple checked all the connections, especially the power cord. I even pulled the power cord and then reset it. Nothing. Dead. It never occurred to me that a fuse would die. Now to find out where the fuse is and how to test if it’s live.

If there is no sign of life at all and you have tried unplugging it and then plugging it in again, then there are only two possibilities:

One is the equipment fuse has blown and the second is a hardware failure which will mean it going back to the Canadian Focal/Naim service agent.

The fuse is located right next to the power cord. Mine is a 240V unit but I think yours will be similar, but with a different fuse. Besides the working one, there is a spare in there. It’s very important to use the correct fuse, which is a slow blow type for a start.

So you unplug the Core, prize out the fuse holder, swap the two fuses over and press the holder back in again. Then power the unit up. Here is where it is located.

If you send the Core unit off to be repaired then I suggest take out the hard drive and keep it at home. You just undo the two screws holding the hard drive caddy into the Core and it will slide out. Keep the screws safe! You don’t need to take the drive out of the caddy. Just keep that whole thing and send the main unit back with a hole in it!

Also if changing the fuse does work, then you need to buy a couple of spare fuses the same day! Best way is to get them from your Naim dealer which should know the exact type.


I second David’s suggestion to check the fuse. As he says, you should find a spare in there.

I hope it’s the fuse! Thanks lots for the good tip.

I had this problem on my original core, when trying to wake from deep sleep mode. If I depressed the power button, no matter how long, it would not come out of deep sleep mode. However, if I depressed the power button on the Core, while I connected the electrical supply i.e, switched the switch to on, on the a.c. socket outlet, you could just push the plug into a.c. socket outlet, when no switch available. Doing the above procedure, enabled the Core to come out of deep sleep every time. Hope this helps, if it relates to the problem you are seeing :blush:

1 Like

Depending on which mains circuit the Core is on, a remaining possibility it that the fuse in the fuse box of the house / apartment triggered for some reason. If the Core happens to be the only active consumer on that circuit, one might not notice by lights going out or whatever

1 Like

Any update, @Echolane?

Yes, good news. I went through the routine again of unplugging it and waiting and then reconnecting it to power. And then pressing the standby button and holding it and this time the unit came to life. I am super relieved!


But I tried to rip another CD tonight and it didn’t want to work again. So I pressed the standby button again and it decided to work. But it doesn’t act normal.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.