How to change language on the Uniti Atom

I’ve just bought a S/H Uniti Atom from a Polish couple.

Works fine with the app, but the front panel says stuff in Polish!

I can’t find where in the settings to change the language. Any ideas?

Reset To Factory?

Very easy, @Raph use remote, press “home” then select settings and first item on the settings list is language.
The icon - use remote navigation arrows - is on the bottom row, last icon to right.

Good idea though, to do a factory reset in any case, to remove all previous settings. I am not sure whetheer that would change the language though.

Wow - brilliant! I hadn’t thought of trying the remote, I was searching in the app.

Thank you!