How to reliably lose your connection with the Naim app

HI all,

I have been listening to a lot of play lists over Christmas and I have discovered what it is that makes the NDX (in my case) lose it’s connection with the Naim app. The only way to recover is to power cycle the NDX and kill off the app on your iPad.

The trick is this:

  1. While playing a play list hit the pause button on your Naim remote.
  2. Walk away (to let guests into the house and pour them drinks)
  3. Hit pause again on your remote and the system will go dead
  4. Try to connect using the Naim app and it claims that it can’t connect.
  5. Gnash teeth and turn off the NDX for at least 30 seconds and restart the app
  6. Magically it will come back to life

Why did I write this?
So that you don’t use the pause button on your remote and get frustrated like me AND
Hopefully someone from Naim will read this and fix the bug in the next firmware update?

Happy New Year
Jack

2 Likes

Possibly an NDX quirk? I have had no such problems with the NDX2, Nova or Muso Qb.

I think it’s a network quirk. I have no such problems with my 272, SuperUniti , Qb Gen 1, Nova or Core. Mind you I am using Apple not Android phones/tablets.

So is the OP.

I’ve never encountered this problem with my NDX, but I don’t use it with the NDX remote, it’s an item that’s practically unused, I use the iPad for all NDX specific operations, including the amp volume during NDX replay.
I just tried the OP steps & it does not seem to behave the same.
I’ll give it another go this evening

I do have these issues. But i do not need to pause the NDX. NDX stops playing after completing a song and only way to reconnect by shutting off the NDX. Trying to reconnect with the app does not work. Can not find it, or other cliënt connected.
NDX is connect with wire. And I do have a “mesh?” system.
Adroid phone.
Tidal streaming. I dont think it happens with internet radio.

My Superuniti looses network too after longer breaks. Funny enough, the “network scan” function in the app detects the SU and even says the connection is “Great”, but the SU cannot be accessed. Technical reason? For all I know my network is perfect.
Power it off and back on, that’s it. No need to wait 30 seconds though. It never leaves me in a listening session, regardless how long this is.
So yes, a quirk, but one I can live with. Like the Focal thing on the app.

I just realised I didn’t specify TIDAL playlist. I have also noticed while playing an album on TIDAL, pausing and going away to answer the door or something that when I come back the NDX refuses to play and the app disconnects. I have tried to just restart the app but that doesn’t work. I have to power cycle the NDX and restart the app for a reliable connection. The workaround is to change to FM radio before I leave the room and when I come back it’s still playing OK. I think Chielheirpuntnl (boy you must have fun explaining that name at parties!) may be onto something with internet radio too. I’ll try that and see if that’s OK. It maybe only when playing TIDAL and pausing that this lockout occurs.

What happens if you get the lockout in Tidal as you describe but change to another input like internet radio or local upnp streaming after that and then change back to Tidal?

Just tried that - funny. Obviously you cannot do it via the app, but if you use the remote to switch to (for example) TV, sound is back - provided TV is on. Plus app is connected again, so is Tidal. Really strange.

There have been a number of legacy streamer users reporting a problem with the app losing the room since the latest firmware update. I get the problem occasionally and it can be remedied by cycling the iRadio input or any of the radio presets on the remote. This option takes almost as much time as it takes to cycle the power on the streamer.

The problem in my system occurs when I’m cycling from a upnp playlist; upnp/minimstreamer/m3u playlist or upnp/bubblesoft/Qobuz playlist to local streaming upnp/asset/local files. Moving too quickly b/w these sources seems to cause the app to get confused and hang up and ultimately losing the room requiring the aforementioned remedy. It was happening more often after the firmware update but is more seldom now mostly b/c I’ve changed my behavior to limit the problem (I think).

I have a similar problem with my 272.

When the app drops connection to the NAS Drive ( Asset UPNP) an odd work around I have found is to keep another app called “MusicSteamer” by Stratospherix open.
When the Naim app drops the connection. Go to the MusicStreamer app, it will automatically connect to the NAS. Go back to the Naim app and hey presto connection is restored. I guess Stratospherix has a much more reliable solution.

1 Like