Incorrect Network message - Uniti Atom

Hi All
After a few years of music streaming via wifi, I have recently changed my Atom’s connection to an Ethernet cable.
everything is great (no sound quality change at least for my ears if anyone wondered) except an annoying message on the Atom’s screen saying there is “No Network Connection” (see attached Pic).
so… I guess that it has popped up because the unit does not connect anymore via wifi. I have tried to look at the Atom’s settings and in the App settings but everything seems to be at place.
I would love to get rid of it.

any thoughts?

If you haven’t done so already I would disconnect the Atom from the mains for 15 to 20 minutes and then reconnect, this sometimes clears issues similar to this.
If that hasn’t or doesn’t work then someone like @davidhendon might be able to offer advice.

Paul’s suggestion above is worth a try. If it doesn’t work, a factory reset should do it, but of course you will lost any settings you may have changed and will have to start again.

1 Like

This does not have anything to do with the wifi connection, pretty sure it should detect the network connection. And as far as I know this should override de Wifi setup.

You should try selecting the “Network setup” option at the bottom.

If, after a restart and selecting Network setup, this is not solved a reboot of your network hardware may be in order.

If you have a laptop connect it to the same connection using the same cable, does it get an IP address / internet connection ?

thank you for responding.
@paulbysea I do not remember if I have rebooted the Atom lately, I will try tonight and will update.
@ChrisSU I am trying to avoid a factory reset. hope it will not be necessary (FYI NAIM software team).
@Kryptos you are right mentioning “it should detect the network connection” but it’s not and this is the issue here.
@NogBadTheBad If I failed to mention before, the Atom streams data fine using the ethernet cable. it is not an internet connection problem.


So it does what it is supposed to changes to wired network when a wired connectin is established. As another person suggested check in the app room name settings that wired is used. The few times I did change from wireless to wired on nd555 I did not see such messages.