iOS 14 Bluetooth issues with your Naim streamer?

I was trying to connect from my iPad and iPhone to the ND555 via Bluetooth but the Apple devices won’t find the streamer. I have an old iPad (not yet updated to the latest iOS) and it connects fine. Anyone else finding the same issue with their Naim streamer and an iOS 14 device?

14 has been out for a while now, so I suspect would have been reported by now if it were an issue. Have you retried a restart of the iPad, and possibly the router?

Thanks @GadgetMan.
I tried turning off the iPad which didn’t solve anything but in the end resetting network settings on my iPad suddenly allowed the ND555 to pop up in Bluetooth devices again.

Being a big fan of apple, simplicity & everything ‘talks to each other’ & still owning my iphone 3g, I have owned most of the phones & currently have a 12. I have been VERY disappointed with their recent updates (13 & 14). My ‘Guru’ (friend - built his own 3D printer from scratch) told me not to update to 14, & I still haven’t. This thread confirms to me, even more so, not to update yet - c’mon Apple; you’re better than this.
To the op: ‘reboot’ very often helps - hope all ‘comes back togeter’ :blush:

Thanks @JR007
All good now. Resetting all the network settings on my iOS devices did the trick for me. I know it’s great when it all just works, but I now expect to have to do a little bit of troubleshooting to keep things working as they should. I am not very technical so it’s probably good for me! :see_no_evil:


Just updated my two iPads to 14 and Bluetooth to my Atom worked straight off on both of them.


1 Like

Great, good news @PeakMan. My issues seemed to have been related to my devices rather than anything to do with my Naim streamer.

I know this thread is related to Bluetooth, but I have noticed that my Airplay connections have become more stable. I played the same music to a MuSo Gen2 and QB Gen1 simultaneously with much no dropping out hor problems. Previously one or the other device would sporadically drop out or develop a fitful connection.

1 Like

Great @VikasMG
This is turning into a ‘good news’ thread!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.