Is quboz down?

Just trying Cambridge streamer and I can’t log into quboz either through Roon or direct in their app. Just flashes up error please try later? Anyone else?

Same for me on Innuos :confused:

1 Like

And me nothing there on Naim app.

1 Like

Ah good in a way then, not something I’ve done wrong.

It would appear so. It’s logged me out the Qobuz app and it’s not accepting my password :man_shrugging:t2:

It’s vtuner all over :rofl:

Had the same this afternoon. Apparently they’ve done some updates and to get them to work, log you out, then when you log back in all is updated.

Took two or three goes to get back in, left it ten minutes and tried again. Now appears to be OK.


I’m glad you’ve raised this, because I can’t connect either. If I touch the Qobuz icon in either the production or Beta app, it does nothing. The input doesn’t change. If I hold on the icon it reverses to a black image on white, but still won’t connect. I’ve tried both ND555 and ND5XS2.

I had just changed my usb connection from one Dac to the other, convinced I had broken something😯


Same with bubbleupnp

Looks like they’ve changed or broken the authentication process

Damn… I just did a power cycle and thought I’d wrecked something… phew!


I’ve been having issues with Qobuz for last few hours, still seems problematic.

Spoke too soon.

Tried it just now, nada.


Qobuz down, including their website, fingers crossed they get up and running soon.

Luckily can play all my cd’s direct from Roon nucleus.


Totally down. Even their www is. Luckily I just started a Tidal 30 day trial to evaluate MAX. Sounds promising.

Won’t let me log in now!

1 Like

Same issue here. Just relieved it’s not my incompetence!

I can play ripped CD’s from innuOS but Qobuz saved favourites are acting up, missing tracks etc. Just received an email telling me Qobuz has failed a monitoring check ?

Within the past two hours, it stopped working, asked me to log in again, worked, and then failed again.