Issue connecting with mesh wifi

I recently updated my home router to a mesh network, but also kept the old router active as I have an integrated modem/router. I can still access my Uniti Core using the old network, but can’t access it with the new mesh network. Any solutions? Thanks!

Make and model of Mesh stuff


I suspect both old and new routers are on separate IP ranges with their own DHCP service running. If you have one router plugged into the other you will have double NAT and 2 isolated network subnets. You need to disable NAT on one device (prob the new mesh kit) and make it a simple bridge to the main internet network, this way both will be on the same network subnet.

Thanks! I’m a complete novice at this, so is there a layman’s guide for how to implement this? I went into the settings on my new router and found a way to convert from dynamic to static. Do I just do this or is it more complicated?

Have you tried plugging the Core into Ethernet port 3 or 4 on the new Arris router?

Hi @Stevem, @Pipdan is right here in that you appear to have two routers running back to back which will create a number of issues and conflicts.

Ideally you need to have just one router on your LAN, probably the easiest way to ensure that is to set up the new Surfboard to function as a network bridge (rather than a router) to your existing modem/router.

You will need the ARRIS SURFboard mAX Manager app on your iOS or Android device to guide you through a complete setup.

Hmm, simple for a network engineer but will be like a foreign language if its not something you work with. I downloaded the instructions for your device, the critical bit will be the operating mode first eluded to on page 13. You are asked what your current network is, if you this wrong then its start again time.

The wording is not very clear and there’s no network diagram to help but best guess i would try

“Gateway with integrated WiFi”
I would expect you connect the Arris WAN port with a cable you your old router

This i think will retain your current router function and put the arris into bridge mode, which basically means its WiFi network is bridged to its cable network. So, if you plug the cable network into your existing router it will be bridged to the new WiFi, which is what you want.

Hope that helps

By connecting the Arris WAN port to the old router the Arris thinks this is the internet so the Arris is running in it’s own bubble.

Yes but that’s only if the Arris is in router mode. If you configure as a bridge then the WAN port will be correct.

I missed your post Pipdan when I replied.


Thanks for all the great advice! I did 2 things based on your recommendations – bridged the old modem to the new router, which turned off the old router, and physically connected the Naim to the new router. It’s now working!

1 Like

On this topic I have just purchased the BT Whole Home package, plan to set up tomorrow, however, before I do…my switch currently goes into my virgin hub, in the new set up should I connect the switch to the BT Disc that is wired into the Hub?

Hi, I checked the BT instructions, even worse than the Arris. They don’t say how the kit works at a network level. I guess there 2 main possibilities:

  1. The kit is designed to bridge, in which case it won’t matter and the new Wi-Fi will be linked to the cabled network anyway. In this case you can plug your switch into the Virgin hub or the BT disk.

  2. The kit will NAT to the cabled side of its network, in which case you won’t be able to use the Virgin Hub network Ports or the old Virgin Wi-Fi. In this scenario I would hope the ports on the BT disk are bridged to its Wi-Fi, but the online info does not say. You’d just have to try it.


Thanks, I think I will initially keep the switch plugged directly into the Hub*, set up the system and see where it takes me…

*logically that makes more sense to me, I.e direct connection, however, I’m no telecoms expert :joy:

Some devices can work either way – Apple Airport Extreme is one such device. So if your home ‘hub’ (router) is ruling your home network, you set up your wifi ‘hub’ with NAT turned OFF. Otherwise, you’ll end up with two different networks that won’t talk to each other.

For most users, who buy these devices only for the home wifi function, NAT should be OFF on them, as they are relying on their internet service provider’s router to provide ip addresses for devices in the home.

How are you connecting your new wifi access points to your router… I assume you are connecting them to one of your router switch ports?

I am not familiar with your Arris product, but it should be a regular AP.

If however it’s some sort of consumer router cum access point… you will need to disable the router part. Wifi access points really should not be incorporating such things…

The BT Whole Home product is very straightforward… it just connects to your router switch ports (but ensure these are kosher switchports) … there is no so called double NATing or NATing etc… which you should NEVER do anyway unless you are using very advanced configuration and advanced equipment for layer 2 communication. Many applications such as SIP communications will fail with NATing unless your NATing device is SIP aware… anyway the BT product acts as a regular access points on your subnet… wifi works at layer 2 and not layer 3, so IP addresses are (or should be) irrelevant.

FWIW, I just upgraded to two Asus RT-AC 86U routers, both wired to the LAN. I have tried enabling their proprietary “AI-MESH” system twice, with unsatisfactory results. Mesh is supposed to improve hand-offs and through-put. They work more reliably with Mesh turned off, one set as router and the other as access point. In this mode, WiFi is the best I have ever had. Replaced Apple Extreme plus two AirPort Express repeaters that never were reliable.

Cheap enough at under $200 USD each.


Thx for that. Arris was more expensive but mesh network was very easy to set up and works beautifully.